blob: 9edcb2b6e1000fc650ddffa4ec7911af655b73ea [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "OpenGL Mathematics Library"
2DESCRIPTION = "OpenGL Mathematics (GLM) is a header only C++ \
3mathematics library for graphics software based on the OpenGL \
4Shading Language (GLSL) specifications."
5HOMEPAGE = "https://glm.g-truc.net"
6BUGTRACKER = "https://github.com/g-truc/glm/issues"
7SECTION = "libs"
8LICENSE = "MIT"
Andrew Geisslerac970dd2021-02-12 15:32:45 -06009LIC_FILES_CHKSUM = "file://copying.txt;md5=462e4b97f73ef12f8171c3c546ce4e8d"
Brad Bishope42b3e32020-01-15 22:08:42 -050010
11SRC_URI = " \
Andrew Geissler595f6302022-01-24 19:11:47 +000012 git://github.com/g-truc/glm;branch=master;protocol=https \
Andrew Geisslerac970dd2021-02-12 15:32:45 -060013 file://0001-Silence-clang-warnings.patch \
Brad Bishope42b3e32020-01-15 22:08:42 -050014 file://glmConfig.cmake.in \
15 file://glmConfigVersion.cmake.in \
16 file://glm.pc.in \
17 file://glmTargets.cmake \
18"
Andrew Geisslerac970dd2021-02-12 15:32:45 -060019SRCREV = "bf71a834948186f4097caa076cd2663c69a10e1e"
Brad Bishope42b3e32020-01-15 22:08:42 -050020
21S = "${WORKDIR}/git"
22
23inherit cmake
24
Andrew Geissler87f5cff2022-09-30 13:13:31 -050025CXXFLAGS:append:toolchain-clang = " -Wno-error=invalid-utf8 -Wno-error=disabled-macro-expansion -Wno-error=reserved-identifier"
26
Brad Bishope42b3e32020-01-15 22:08:42 -050027do_install() {
28 install -d ${D}${includedir} ${D}${docdir}/glm ${D}${libdir}/pkgconfig ${D}${libdir}/cmake/glm
29 cp -R --no-dereference --preserve=mode,links ${S}/glm ${D}${includedir}
30 cp -R --no-dereference --preserve=mode,links ${S}/doc ${D}${docdir}/glm
31 rm ${D}${includedir}/glm/CMakeLists.txt
32 sed "s/@VERSION@/${PV}/" ${WORKDIR}/glmConfigVersion.cmake.in > ${D}${libdir}/cmake/glm/glmConfigVersion.cmake
33 sed "s/@VERSION@/${PV}/" ${WORKDIR}/glmConfig.cmake.in > ${D}${libdir}/cmake/glm/glmConfig.cmake
34 sed "s/@VERSION@/${PV}/" ${WORKDIR}/glm.pc.in > ${D}${libdir}/pkgconfig/glm.pc
35 install -Dm644 ${WORKDIR}/glmTargets.cmake ${D}${libdir}/cmake/glm/glmTargets.cmake
36
37}
38
Patrick Williams213cb262021-08-07 19:21:33 -050039RDEPENDS:${PN}-dev = ""
Brad Bishope42b3e32020-01-15 22:08:42 -050040
41BBCLASSEXTEND = "native"