blob: 7e24c51f280c97e4c29537f13054fcc7f5c1b576 [file] [log] [blame]
Andrew Geissler87f5cff2022-09-30 13:13:31 -05001# SPDX-FileCopyrightText: Huawei Inc.
2# SPDX-License-Identifier: MIT
3
4SRC_URI = "gitsm://git.ostc-eu.org/rzr/dialog-lvgl;destsuffix=${S};protocol=https;nobranch=1"
5SRCREV = "5d2121457a6988c97cacb0790594440693fc3d29"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=8ce0a84e5276f01364119c873b712c4f"
9AUTHOR = "Philippe Coval <philippe.coval.ext@huawei.com>"
10
11DEPENDS += "lvgl"
12DEPENDS += "lv-drivers"
13
14SUMMARY = "Basic UI utility to be used in scripts"
15DESCRIPTION = "Inspired by ncurses' dialog, implemented using LVGL"
16HOMEPAGE = "https://git.ostc-eu.org/rzr/dialog-lvgl/-/wikis/"
17
18REQUIRED_DISTRO_FEATURES = "wayland"
19
20inherit pkgconfig
21inherit features_check
22
23EXTRA_OEMAKE += "sysroot=${RECIPE_SYSROOT}"
24EXTRA_OEMAKE += "DESTDIR=${D}"
25EXTRA_OEMAKE += "lvgl_driver=wayland"
26
27do_install() {
28 oe_runmake install
29}