blob: 64bcf5f7641ff4067af0ed1f5eb444453fb7f3f7 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "ipmiutil is an easy-to-use set of IPMI server management utilities.\
2It can get/set sensor thresholds, automate SEL management, do SOL console, etc."
3
4DESCRIPTION = "The IPMI Management Utilities currently work with platforms that \
5support the IPMI 1.5 or 2.0 specification. IPMI servers can be managed\
6locally, or remotely via IPMI LAN, even when the OS or main CPU is not\
7functional.\n \
8The ipmiutil utilities will use an IPMI Driver, either the Intel IPMI package \
9(ipmidrvr, /dev/imb), MontaVista OpenIPMI (/dev/ipmi0), the valinux IPMI \
10Driver (/dev/ipmikcs), or the LANDesk ldipmi daemon. The ipmiutil utilities \
11can also use direct user-space I/Os in Linux or FreeBSD if no IPMI driver \
12is detected."
13
14HOMEPAGE = "http://ipmiutil.sourceforge.net"
15LICENSE = "BSD-2-Clause"
16LIC_FILES_CHKSUM = "file://COPYING;md5=626a5970304daa1fcb87f757fb42b795"
17
18DEPENDS += "openssl"
19
20PARALLEL_MAKE = ""
21
22SRC_URI = "${SOURCEFORGE_MIRROR}/ipmiutil/ipmiutil-${PV}.tar.gz \
23 file://fix_systemd_path.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050024 file://0001-Prevent-access-times-from-changing-resulting-gzip-md.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050025 file://0001-ihpm-Include-stdlib.h-for-malloc-free-atoi-functions.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026 "
Brad Bishope42b3e32020-01-15 22:08:42 -050027SRC_URI[md5sum] = "292d6df25cad678bb27e5c8cdc6748f9"
28SRC_URI[sha256sum] = "58ccdbd5755d7dd72478756715af09e9c73330dfad2b91dbf03d2ac504b301a3"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050029
30inherit autotools-brokensep pkgconfig systemd
31
32PACKAGECONFIG ?= "lanplus gpl"
33PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
34PACKAGECONFIG[systemd] = "--enable-systemd=${datadir}/${BPN}, --enable-systemd=no"
35PACKAGECONFIG[sha256] = "--enable-sha256, --enable-sha256=no, openssl-native, openssl"
36PACKAGECONFIG[lanplus] = "--enable-lanplus, --enable-lanplus=no, openssl-native, openssl"
37PACKAGECONFIG[landesk] = "--enable-landesk, --enable-landesk=no"
38PACKAGECONFIG[sensors] = "--enable-libsensors, --enable-libsensors=no"
39
40#build with some GPL code
41PACKAGECONFIG[gpl] = "--enable-gpl, --enable-gpl=no"
42#no GPL or LanPlus libs
43PACKAGECONFIG[standalone] = "--enable-standalone, --enable-standalone=no"
44
45CFLAGS += "-I${STAGING_INCDIR}"
46LDFLAGS += "-L${STAGING_LIBDIR}"
47
48COMPATIBLE_HOST = '(x86_64|i.86).*-linux'