blob: 8462701b31f27ac250346a98f46294bed9027fca [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "A password/passphrase strength checking and enforcement toolset"
2DESCRIPTION = "\
3passwdqc is a password/passphrase strength checking and policy enforcement \
4toolset, including an optional PAM module (pam_passwdqc), command-line \
5programs (pwqcheck and pwqgen), and a library (libpasswdqc). \
6pam_passwdqc is normally invoked on password changes by programs such as \
7passwd(1). It is capable of checking password or passphrase strength, \
8enforcing a policy, and offering randomly-generated passphrases, with \
9all of these features being optional and easily (re-)configurable. \
10\
11pwqcheck and pwqgen are standalone password/passphrase strength checking \
12and random passphrase generator programs, respectively, which are usable \
13from scripts. \
14\
15libpasswdqc is the underlying library, which may also be used from \
16third-party programs. \
17"
18
19HOMEPAGE = "http://www.openwall.com/passwdqc"
20SECTION = "System Environment/Base"
21
22DEPENDS += "libpam"
23
Brad Bishop8410d612019-11-25 09:40:59 -050024inherit features_check
Brad Bishop316dfdd2018-06-25 12:45:53 -040025REQUIRED_DISTRO_FEATURES = "pam"
26
Brad Bishop2d39a062019-10-28 08:33:36 -040027LICENSE = "BSD-1-Clause"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050028LIC_FILES_CHKSUM = "file://LICENSE;md5=ac99c8678577a1c2f9f04cccee411d5d"
Brad Bishop316dfdd2018-06-25 12:45:53 -040029
30SRC_URI = "http://www.openwall.com/${BPN}/${BP}.tar.gz \
31 file://makefile-add-ldflags.patch \
32 "
Andrew Geissler87f5cff2022-09-30 13:13:31 -050033SRC_URI[sha256sum] = "ff1f505764c020f6a4484b1e0cc4fdbf2e3f71b522926d90b4709104ca0604ab"
Brad Bishop316dfdd2018-06-25 12:45:53 -040034
35# explicitly define LINUX_PAM in case DISTRO_FEATURES no pam
36# this package's pam_passwdqc.so needs pam
Patrick Williams213cb262021-08-07 19:21:33 -050037CFLAGS:append = " -Wall -fPIC -DHAVE_SHADOW -DLINUX_PAM"
Brad Bishop316dfdd2018-06-25 12:45:53 -040038
39# -e is no longer default setting in bitbake.conf
40EXTRA_OEMAKE = "-e"
41
42do_compile() {
43 # make sure sub make use environment to override variables in Makefile
44 # Linux) $(MAKE), there is a tab between
45 sed -i -e 's/Linux) $(MAKE) CFLAGS_lib/Linux) $(MAKE) -e CFLAGS_lib/' ${S}/Makefile
46
47 # LD_lib and LD must be CC because of Makefile
48 oe_runmake LD="${CC}"
49}
50
51do_install() {
52 oe_runmake install DESTDIR=${D} SHARED_LIBDIR=${base_libdir} \
53 DEVEL_LIBDIR=${libdir} SECUREDIR=${base_libdir}/security \
54 INSTALL="install -p"
55}
56
57PROVIDES += "pam-${BPN}"
58PACKAGES =+ "lib${BPN} pam-${BPN}"
59
Andrew Geissler87f5cff2022-09-30 13:13:31 -050060FILES:lib${BPN} = "${base_libdir}/libpasswdqc.so.1"
Patrick Williams213cb262021-08-07 19:21:33 -050061FILES:pam-${BPN} = "${base_libdir}/security/pam_passwdqc.so"
62FILES:${PN}-dbg += "${base_libdir}/security/.debug"
Brad Bishop316dfdd2018-06-25 12:45:53 -040063
Patrick Williams213cb262021-08-07 19:21:33 -050064RDEPENDS:${PN} = "lib${BPN} pam-${BPN}"
65RDEPENDS:pam-${BPN} = "lib${BPN}"