blob: 53a57489fe51bddcaa8683a125319101d677ae8e [file] [log] [blame]
Andrew Geissler87f5cff2022-09-30 13:13:31 -05001SUMMARY = "C++11 command line parser"
2DESCRIPTION = "A command line parser for C++11 and beyond that provides a rich feature set with a simple and intuitive interface."
3HOMEPAGE = "https://github.com/CLIUtils/CLI11"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=9ad746b5f49c0fd53c08ca1faff1922c"
6SRCREV = "b9be5b9444772324459989177108a6a65b8b2769"
7PV .= "+git${SRCPV}"
8
9SRC_URI += "gitsm://github.com/CLIUtils/CLI11;branch=main;protocol=https \
10 https://github.com/philsquared/Catch/releases/download/v2.13.7/catch.hpp \
11 file://0001-Do-not-download-the-catch-framework-during-configure.patch"
12
13SRC_URI[sha256sum] = "ea379c4a3cb5799027b1eb451163dff065a3d641aaba23bf4e24ee6b536bd9bc"
14S = "${WORKDIR}/git"
15
16do_configure:prepend() {
17 mkdir -p ${S}/tests/catch2
18 cp ${DL_DIR}/catch.hpp ${S}/tests/catch2/catch.hpp
19}
20
21inherit cmake
22inherit ptest
23
24# cli11 is a header only C++ library, so the main package will be empty.
25RDEPENDS:${PN}-dev = ""