blob: e9d30977fe38f73d12acac82d737eb11086473af [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Hard disk temperature monitor daemon"
2SECTION = "console/network"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-2.0-or-later"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05004
5PR = "r1"
6
7SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/hddtemp/hddtemp-0.3-beta15.tar.bz2 \
8 file://hddtemp-no-nls-support.patch \
9 file://hddtemp_0.3-beta15-52.diff \
10 file://hddtemp-0.3-beta15-autodetect-717479.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050011 file://0001-backtrace-Replace-struct-ucontext-with-ucontext_t.patch \
Brad Bishope42b3e32020-01-15 22:08:42 -050012 file://0001-configure.ac-Rename-to-configure.ac-and-use-external.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013 file://0001-sata.c-Declare-ata_get_powermode-prototype.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050014 file://hddtemp.db \
15 file://init \
16"
17
18SRC_URI[md5sum] = "8b829339e1ae9df701684ec239021bb8"
19SRC_URI[sha256sum] = "618541584054093d53be8a2d9e81c97174f30f00af91cb8700a97e442d79ef5b"
20
21LIC_FILES_CHKSUM = "file://GPL-2;md5=eb723b61539feef013de476e68b5c50a"
22
23inherit autotools gettext update-rc.d
24
Patrick Williams213cb262021-08-07 19:21:33 -050025FILES:${PN} += "/usr/share/misc/hddtemp.db"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050026
Patrick Williams213cb262021-08-07 19:21:33 -050027do_install:append() {
Patrick Williamsb48b7b42016-08-17 15:04:38 -050028 install -d ${D}/usr/share/misc/
29 install -m 0644 ${WORKDIR}/hddtemp.db ${D}/usr/share/misc/hddtemp.db
30 install -d ${D}${sysconfdir}/init.d
31 install -m 0644 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hddtemp
32}
33
34INITSCRIPT_NAME = "hddtemp"
35INITSCRIPT_PARAMS = "start 99 2 3 4 5 . stop 20 0 1 6 ."