blob: e408c4db5adf40dd8cb2c6710da163a57cf3fb5d [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Hardware identification and configuration data"
2HOMEPAGE = "https://github.com/vcrhonek/hwdata"
3SECTION = "System/Base"
4
5LICENSE = "GPL-2.0-or-later | XFree86-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=1556547711e8246992b999edd9445a57"
7
Andrew Geissler87f5cff2022-09-30 13:13:31 -05008SRCREV = "8a3647e5da0a157cbf1bff1845b0cdaf1ce1bdb0"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009SRC_URI = "git://github.com/vcrhonek/${BPN}.git;branch=master;protocol=https"
10S = "${WORKDIR}/git"
11
12inherit allarch
13
14do_configure() {
15 ${S}/configure --datadir=${datadir} --libdir=${libdir}
16}
17
18do_compile[noexec] = "1"
19
20do_install() {
21 oe_runmake install DESTDIR=${D}
22}
23
24FILES:${PN} = "${libdir}/* \
25 ${datadir}/* "