blob: 421823d9cdd6d090dd47ab84aed307c235109c83 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "lib-curses provides an interface between Perl programs and \
2the curses library."
3
4SECTION = "libs"
5LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
6
7LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=0b37356c5e9e28080a3422d82af8af09"
8
9DEPENDS += "perl ncurses "
10
Andrew Geissler87f5cff2022-09-30 13:13:31 -050011SRC_URI = "http://www.cpan.org/authors/id/G/GI/GIRAFFED/Curses-${PV}.tar.gz \
12 file://0001-testtyp.c-Use-proper-prototype-for-main-function.patch \
13 "
Patrick Williams92b42cb2022-09-03 06:53:57 -050014
15SRC_URI[sha256sum] = "fb9efea8c7b5ed5f8ea5dee49d35252accfc05ee6e75cb9a37ab7c847cd261d7"
16
17S = "${WORKDIR}/Curses-${PV}"
18
Andrew Geissler87f5cff2022-09-30 13:13:31 -050019EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS=-L${STAGING_LIBDIR} TEST_SYMS_OPTS=-v"
20
21# enable NCURSES_WIDECHAR=1 only if ENABLE_WIDEC has not been explicitly disabled (e.g. by the distro config).
22# When compiling against the ncurses library, NCURSES_WIDECHAR needs to explicitly set to 0 in this case.
23CFLAGS:append:libc-musl = "${@' -DNCURSES_WIDECHAR=1' if bb.utils.to_boolean((d.getVar('ENABLE_WIDEC') or 'True')) else ' -DNCURSES_WIDECHAR=0'} -DNCURSES_INTERNALS"
Patrick Williams92b42cb2022-09-03 06:53:57 -050024
25inherit cpan
26
27do_compile() {
28 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
29 cpan_do_compile
30}
31