blob: e1b8a755d52143cefc63e49f36e7e10fd257c2e4 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "Google gRPC tools"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
7
8inherit pypi setuptools3
9
10DEPENDS += "${PYTHON_PN}-grpcio"
11
Andrew Geissler87f5cff2022-09-30 13:13:31 -050012SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \
13 file://0001-protobuf-Disable-musttail-attribute-on-mips.patch \
14 "
15SRC_URI[sha256sum] = "84cc64e5b46bad43d5d7bd2fd772b656eba0366961187a847e908e2cb735db91"
Patrick Williams92b42cb2022-09-03 06:53:57 -050016
17RDEPENDS:${PN} = "${PYTHON_PN}-grpcio"
18
19BBCLASSEXTEND = "native nativesdk"