blob: b9dc4722af53860f7c4152b9287e57108862a8b6 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001# This recipe is originally from meta-openstack:
2# https://git.yoctoproject.org/cgit/cgit.cgi/meta-cloud-services/tree/meta-openstack/recipes-devtools/python/python-lockfile_0.12.2.bb
3
4SUMMARY = "Platform-independent file locking module"
5HOMEPAGE = "https://pypi.org/project/lockfile/"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=2340dffbbfea534b58f1349984eeef72"
8
9SRC_URI[md5sum] = "a6a1a82957a23afdf44cfdd039b65ff9"
10SRC_URI[sha256sum] = "6aed02de03cba24efabcd600b30540140634fc06cfa603822d508d5361e9f799"
11
12inherit pypi setuptools3
13
14DEPENDS += "python3-distutils-extra-native python3-pbr-native"
Patrick Williams213cb262021-08-07 19:21:33 -050015RDEPENDS:${PN} += "python3-sqlite3"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17BBCLASSEXTEND = "native nativesdk"