blob: 1a0b93b03079d9c8c7d0ed289c184ea2af9d965c [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "matplotlib: plotting with Python"
2DESCRIPTION = "\
3Matplotlib is a Python 2D plotting library which produces \
4publication-quality figures in a variety of hardcopy formats \
5and interactive environments across platforms."
6HOMEPAGE = "https://github.com/matplotlib/matplotlib"
7SECTION = "devel/python"
8LICENSE = "PSF-2.0"
9LIC_FILES_CHKSUM = "\
10 file://setup.py;beginline=296;endline=296;md5=20e7ab4d2b2b1395a0e4ab800181eb96 \
11 file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \
12"
13
14DEPENDS = "\
15 freetype \
16 libpng \
17 python3-numpy-native \
18 python3-pip-native \
19 python3-dateutil-native \
20 python3-pytz-native \
21 python3-certifi-native \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050022 python3-setuptools-scm-native \
Patrick Williams92b42cb2022-09-03 06:53:57 -050023"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050024SRC_URI[sha256sum] = "339cac48b80ddbc8bfd05daae0a3a73414651a8596904c2a881cfd1edb65f26c"
Patrick Williams92b42cb2022-09-03 06:53:57 -050025
26inherit pypi setuptools3 pkgconfig
27
28# Stop the component from attempting to download when it detects a missing
29# dependency
30SRC_URI += "file://matplotlib-disable-download.patch"
31
32# This python module requires a full copy of freetype-2.6.1
33SRC_URI += "https://downloads.sourceforge.net/project/freetype/freetype2/2.6.1/freetype-2.6.1.tar.gz;name=freetype;subdir=matplotlib-${PV}/build"
34SRC_URI[freetype.sha256sum] = "0a3c7dfbda6da1e8fce29232e8e96d987ababbbf71ebc8c75659e4132c367014"
35
36# This python module requires a full copy of 'qhull-2020'
37SRC_URI += "http://www.qhull.org/download/qhull-2020-src-8.0.2.tgz;name=qhull;subdir=matplotlib-${PV}/build"
38SRC_URI[qhull.sha256sum] = "b5c2d7eb833278881b952c8a52d20179eab87766b00b865000469a45c1838b7e"
39
40# LTO with clang needs lld
41LDFLAGS:append:toolchain-clang = " -fuse-ld=lld"
42LDFLAGS:remove:toolchain-clang:mips = "-fuse-ld=lld"
Patrick Williams92b42cb2022-09-03 06:53:57 -050043RDEPENDS:${PN} = "\
44 freetype \
45 libpng \
46 python3-numpy \
47 python3-pyparsing \
48 python3-cycler \
49 python3-dateutil \
50 python3-kiwisolver \
51 python3-pytz \
52 python3-pillow \
53 python3-packaging \
54"
55
56ENABLELTO:toolchain-clang:riscv64 = "echo enable_lto = False >> ${S}/mplsetup.cfg"
57ENABLELTO:toolchain-clang:riscv32 = "echo enable_lto = False >> ${S}/mplsetup.cfg"
58ENABLELTO:toolchain-clang:mips = "echo enable_lto = False >> ${S}/mplsetup.cfg"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050059
Patrick Williams92b42cb2022-09-03 06:53:57 -050060do_compile:prepend() {
61 echo [libs] > ${S}/mplsetup.cfg
62 echo system_freetype = True >> ${S}/mplsetup.cfg
63 ${ENABLELTO}
64}
65
66BBCLASSEXTEND = "native"