blob: c8b50f0b2dcfde0518f21f23dd0fd754138462cf [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Python library for displaying tabular data in a ASCII table format"
2HOMEPAGE = "http://code.google.com/p/prettytable"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c9a6829fcd174d9535b46211917c7671"
5
Andrew Geissler87f5cff2022-09-30 13:13:31 -05006SRC_URI[sha256sum] = "7d7dd84d0b206f2daac4471a72f299d6907f34516064feb2838e333a4e2567bd"
Patrick Williams92b42cb2022-09-03 06:53:57 -05007
8do_install:append() {
9 perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
10 for f in $perm_files; do
11 chmod 644 "${f}"
12 done
13}
14
15UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/PrettyTable/"
16UPSTREAM_CHECK_REGEX = "/PrettyTable/(?P<pver>(\d+[\.\-_]*)+)"
17
18BBCLASSEXTEND = "native nativesdk"
19inherit pypi ptest setuptools3
20
21SRC_URI += " \
22 file://run-ptest \
23"
24
25DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
26
27RDEPENDS:${PN} += " \
28 ${PYTHON_PN}-math \
29 ${PYTHON_PN}-html \
30 ${PYTHON_PN}-wcwidth \
31 ${PYTHON_PN}-json \
32 ${PYTHON_PN}-compression \
33 ${PYTHON_PN}-importlib-metadata \
34"
35
36RDEPENDS:${PN}-ptest += " \
37 ${PYTHON_PN}-pytest \
38 ${PYTHON_PN}-pytest-lazy-fixture \
39 ${PYTHON_PN}-sqlite3 \
40"
41
42do_install_ptest() {
43 cp -f ${S}/tests/test_prettytable.py ${D}${PTEST_PATH}/
44}