blob: 99b6f7c04bf80407323f2935f9e8b7783701d439 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "CSS selector library for python-beautifulsoup4"
2HOMEPAGE = "https://github.com/facelessuser/soupsieve"
3
4LICENSE = "MIT"
Andrew Geissler87f5cff2022-09-30 13:13:31 -05005LIC_FILES_CHKSUM = "file://LICENSE.md;md5=c7a2acf04248c0d02dac4c82ee8a7f56"
Andrew Geissler595f6302022-01-24 19:11:47 +00006
Andrew Geissler87f5cff2022-09-30 13:13:31 -05007SRC_URI[sha256sum] = "fc53893b3da2c33de295667a0e19f078c14bf86544af307354de5fcf12a3f30d"
Andrew Geissler595f6302022-01-24 19:11:47 +00008
Andrew Geissler87f5cff2022-09-30 13:13:31 -05009inherit pypi python_hatchling python_setuptools_build_meta ptest
Andrew Geissler595f6302022-01-24 19:11:47 +000010
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN} += "\
16 ${PYTHON_PN}-beautifulsoup4 \
17"
18
19RDEPENDS:${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21 ${PYTHON_PN}-beautifulsoup4 \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}
28
29BBCLASSEXTEND = "native nativesdk"