blob: f40c5f080bdffca797bc3a84e3546b8eec5634b4 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \
2Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols \
3(including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more."
4HOMEPAGE = "http://www.twistedmatrix.com"
5
6#twisted/topfiles/NEWS:655: - Relicensed: Now under the MIT license, rather than LGPL.
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=0f8d67f84b6e178c92d471011b2245fc"
9
Andrew Geissler87f5cff2022-09-30 13:13:31 -050010SRC_URI[sha256sum] = "e5b60de39f2d1da153fbe1874d885fe3fcbdb21fcc446fa759a53e8fc3513bed"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011
12PYPI_PACKAGE = "Twisted"
13
14inherit pypi python_setuptools_build_meta
15
16do_install:append() {
17 # remove some useless files before packaging
18 find ${D} \( -name "*.bat" -o -name "*.c" -o -name "*.h" \) -exec rm -f {} \;
19}
20
21PACKAGES += "\
22 ${PN}-zsh \
23 ${PN}-test \
24 ${PN}-protocols \
25 ${PN}-conch \
26 ${PN}-mail \
27 ${PN}-names \
28 ${PN}-news \
29 ${PN}-runner \
30 ${PN}-web \
31 ${PN}-words \
32 ${PN}-flow \
33 ${PN}-pair \
34 ${PN}-core \
35"
36
37PACKAGES =+ "\
38 ${PN}-bin \
39"
40
41DEPENDS += " \
42 ${PYTHON_PN}-incremental-native \
43"
44
45RDEPENDS:${PN} = "\
46 ${PN}-bin \
47 ${PN}-core \
48 ${PN}-conch \
49 ${PN}-mail \
50 ${PN}-names \
51 ${PN}-pair \
52 ${PN}-protocols \
53 ${PN}-runner \
54 ${PN}-web \
55 ${PN}-words \
56 ${PN}-zsh \
57"
58
59RDEPENDS:${PN}-core = "${PYTHON_PN}-appdirs \
60 ${PYTHON_PN}-automat \
61 ${PYTHON_PN}-constantly \
62 ${PYTHON_PN}-core \
63 ${PYTHON_PN}-debugger \
64 ${PYTHON_PN}-hyperlink \
65 ${PYTHON_PN}-incremental \
66 ${PYTHON_PN}-pyhamcrest \
67 ${PYTHON_PN}-pyserial \
68 ${PYTHON_PN}-unixadmin \
69 ${PYTHON_PN}-zopeinterface \
70"
71RDEPENDS:${PN}-test = "${PN}"
72RDEPENDS:${PN}-conch = "${PN}-core ${PN}-protocols ${PYTHON_PN}-bcrypt ${PYTHON_PN}-cryptography ${PYTHON_PN}-pyasn1 ${PYTHON_PN}-pickle"
73RDEPENDS:${PN}-mail = "${PN}-core ${PN}-protocols"
74RDEPENDS:${PN}-names = "${PN}-core"
75RDEPENDS:${PN}-news = "${PN}-core ${PN}-protocols"
76RDEPENDS:${PN}-runner = "${PN}-core ${PN}-protocols"
77RDEPENDS:${PN}-web += "${PN}-core ${PN}-protocols"
78RDEPENDS:${PN}-words += "${PN}-core"
79RDEPENDS:${PN}-flow += "${PN}-core"
80RDEPENDS:${PN}-pair += "${PN}-core"
81
82FILES:${PN} = "${PYTHON_SITEPACKAGES_DIR}/${PYPI_PACKAGE}-${PV}.dist-info/*"
83
84FILES:${PN}-test = " \
85 ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \
86 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \
87 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy/test/ \
88"
89
90FILES:${PN}-protocols = " \
91 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/*.py* \
92 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/gps/ \
93 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/mice/ \
94 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy \
95"
96
97FILES:${PN}-zsh = " \
98 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \
99 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \
100 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/twisted-completion.zsh \
101"
102
103FILES:${PN}-conch = " \
104 ${bindir}/ckeygen \
105 ${bindir}/tkconch \
106 ${bindir}/conch \
107 ${bindir}/conchftp \
108 ${bindir}/cftp \
109 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \
110 ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \
111"
112
113FILES:${PN}-core = " \
114${bindir}/manhole \
115${bindir}/mktap \
116${bindir}/twistd \
117${bindir}/tap2deb \
118${bindir}/tap2rpm \
119${bindir}/tapconvert \
120${bindir}/tkmktap \
121${bindir}/trial \
122${bindir}/easy_install* \
123${bindir}/pyhtmlizer \
124${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.so \
125${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
126${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \
127${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \
128${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py* \
129${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py* \
130${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py* \
131${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py* \
132${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py* \
133${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py* \
134${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py* \
135${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py* \
136${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/dropin.cache \
137${libdir}/${PYTHON_DIR}/site-packages/twisted/application \
138${libdir}/${PYTHON_DIR}/site-packages/twisted/cred \
139${libdir}/${PYTHON_DIR}/site-packages/twisted/enterprise \
140${libdir}/${PYTHON_DIR}/site-packages/twisted/internet \
141${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
142${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
143${libdir}/${PYTHON_DIR}/site-packages/twisted/persisted \
144${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols\
145${libdir}/${PYTHON_DIR}/site-packages/twisted/python\
146${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py* \
147${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py* \
148${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py* \
149${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py* \
150${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py* \
151${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py* \
152${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py* \
153${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py* \
154${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py* \
155${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py* \
156${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py* \
157${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py* \
158${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py* \
159${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py* \
160${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py* \
161${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py* \
162${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py* \
163${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py* \
164${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py* \
165${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py* \
166${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py* \
167${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py* \
168${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py* \
169${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py* \
170${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py* \
171${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py* \
172${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py* \
173${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py* \
174${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py* \
175${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py* \
176${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py* \
177${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py* \
178${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py* \
179${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py* \
180${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py* \
181${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py* \
182${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py* \
183${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_twisted_zsh_stub \
184${libdir}/${PYTHON_DIR}/site-packages/twisted/scripts/ \
185${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/ \
186${libdir}/${PYTHON_DIR}/site-packages/twisted/tap/ \
187${libdir}/${PYTHON_DIR}/site-packages/twisted/trial/ \
188${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \
189${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \
190${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \
191${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \
192${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
193${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \
194${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \
195${libdir}/${PYTHON_DIR}/site-packages/twisted/topfiles \
196${libdir}/${PYTHON_DIR}/site-packages/Twisted*egg-info \
197${libdir}/${PYTHON_DIR}/site-packages/twisted/logger/ \
198${libdir}/${PYTHON_DIR}/site-packages/twisted/_threads/ \
199${libdir}/${PYTHON_DIR}/site-packages/twisted/positioning/ \
200${libdir}/${PYTHON_DIR}/site-packages/twisted/py.typed \
201"
202
203FILES:${PN}-mail = " \
204${bindir}/mailmail \
205${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py* \
206${libdir}/${PYTHON_DIR}/site-packages/twisted/mail \
207"
208
209FILES:${PN}-names = " \
210${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py* \
211${libdir}/${PYTHON_DIR}/site-packages/twisted/names \
212"
213
214FILES:${PN}-news = " \
215${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py* \
216${libdir}/${PYTHON_DIR}/site-packages/twisted/news \
217"
218
219FILES:${PN}-runner = " \
220${libdir}/site-packages/twisted/runner/portmap.so \
221${libdir}/${PYTHON_DIR}/site-packages/twisted/runner\
222"
223
224FILES:${PN}-web = " \
225${bindir}/websetroot \
226${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py* \
227${libdir}/${PYTHON_DIR}/site-packages/twisted/web\
228"
229
230FILES:${PN}-words = " \
231${bindir}/im \
232${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \
233${libdir}/${PYTHON_DIR}/site-packages/twisted/words\
234"
235
236FILES:${PN}-flow = " \
237${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_flow.py* \
238${libdir}/${PYTHON_DIR}/site-packages/twisted/flow \"
239
240FILES:${PN}-pair = " \
241${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_pair.py* \
242${libdir}/${PYTHON_DIR}/site-packages/twisted/pair \
243"
244
245FILES:${PN}-doc += " \
246 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_pydoctortemplates/ \
247"
248
249FILES:${PN}-core:append = " \
250 ${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \
251 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__pycache__/*pyc \
252 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/__init__*.pyc \
253 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/notestplugin*.pyc \
254 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/testplugin*.pyc \
255 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_ftp*.pyc \
256 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_inet*.pyc \
257 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_manhole*.pyc \
258 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_portforward*.pyc \
259 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_socks*.pyc \
260 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_telnet*.pyc \
261 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_trial*.pyc \
262 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_core*.pyc \
263 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_qtstub*.pyc \
264 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_reactors*.pyc \
265 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/cred*.pyc \
266 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/dropin*.cache \
267"
268
269FILES:${PN}-names:append = " \
270 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_names*.pyc \
271"
272
273FILES:${PN}-news:append = " \
274 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_news*.pyc \
275"
276
277FILES:${PN}-protocols:append = " \
278 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/__pycache__/*pyc \
279"
280
281FILES:${PN}-conch:append = " \
282 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_conch*.pyc \
283"
284
285FILES:${PN}-lore:append = " \
286 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_lore*.pyc \
287"
288FILES:${PN}-mail:append = " \
289 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_mail*.pyc \
290"
291
292FILES:${PN}-web:append = " \
293 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_web*.pyc \
294"
295
296FILES:${PN}-words:append = " \
297 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_words*.pyc \
298"
299
300FILES:${PN}-flow:append = " \
301 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_flow*.pyc \
302"
303
304FILES:${PN}-pair:append = " \
305 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_pair*.pyc \
306"
307
308FILES:${PN}-runner:append = " \
309 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_runner*.pyc \
310"