blob: 9f080eb278b1c11b5e6aab9a7a459764ea235842 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Ultra fast JSON encoder and decoder for Python"
2DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
3
4LICENSE = "BSD-3-Clause"
Andrew Geissler615f2f12022-07-15 14:00:58 -05005LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e0039a83d8a99726b5418f0b03302d0a"
Andrew Geissler595f6302022-01-24 19:11:47 +00006
Andrew Geissler87f5cff2022-09-30 13:13:31 -05007SRC_URI[sha256sum] = "b25077a971c7da47bd6846a912a747f6963776d90720c88603b1b55d81790780"
Andrew Geissler595f6302022-01-24 19:11:47 +00008
9inherit pypi ptest setuptools3
10
11SRC_URI += " \
12 file://run-ptest \
13 file://0001-setup.py-Do-not-strip-debugging-symbols.patch \
14"
15
16DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
17
18RDEPENDS:${PN} += "\
19 ${PYTHON_PN}-datetime \
20 ${PYTHON_PN}-numbers \
21"
22
23RDEPENDS:${PN}-ptest += " \
24 ${PYTHON_PN}-json \
25 ${PYTHON_PN}-pytest \
26 ${PYTHON_PN}-pytz \
27"
28
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}/tests
31 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
32}
33
34BBCLASSEXTEND = "native nativesdk"