blob: 97c241a3f5f0a39c7e485bcbcc25e71098d02f5e [file] [log] [blame]
Andrew Geisslerd1e89492021-02-12 15:35:20 -06001SUMMARY = "A GNU tool that produce shell scripts to automatically configure software"
2DESCRIPTION = "Autoconf is an extensible package of M4 macros that produce shell scripts to automatically \
3configure software source code packages. Autoconf creates a configuration script for a package from a template \
4file that lists the operating system features that the package can use, in the form of M4 macro calls."
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "GPL-3.0-or-later"
Andrew Geisslerd1e89492021-02-12 15:35:20 -06006HOMEPAGE = "http://www.gnu.org/software/autoconf/"
7SECTION = "devel"
8DEPENDS = "m4-native autoconf-native automake-native gnu-config-native help2man-native"
Patrick Williams213cb262021-08-07 19:21:33 -05009DEPENDS:remove:class-native = "autoconf-native automake-native help2man-native"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060010
11LIC_FILES_CHKSUM = "file://COPYING;md5=cc3f3a7596cb558bbd9eb7fbaa3ef16c \
12 file://COPYINGv3;md5=1ebbd3e34237af26da5dc08a4e440464"
13
14SRC_URI = "${GNU_MIRROR}/autoconf/${BP}.tar.gz \
15 file://program_prefix.patch \
16 file://autoreconf-exclude.patch \
17 file://remove-usr-local-lib-from-m4.patch \
18 file://preferbash.patch \
19 file://autotest-automake-result-format.patch \
20 file://man-host-perl.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050021 file://0001-Port-to-compilers-that-moan-about-K-R-func-decls.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060022 "
Patrick Williams213cb262021-08-07 19:21:33 -050023SRC_URI:append:class-native = " file://no-man.patch"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060024
25SRC_URI[sha256sum] = "431075ad0bf529ef13cb41e9042c542381103e80015686222b8a9d4abef42a1c"
26
Patrick Williams213cb262021-08-07 19:21:33 -050027RDEPENDS:${PN} = "m4 gnu-config \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060028 perl \
29 perl-module-bytes \
30 perl-module-carp \
31 perl-module-constant \
32 perl-module-data-dumper \
33 perl-module-errno \
34 perl-module-exporter \
35 perl-module-file-basename \
36 perl-module-file-compare \
37 perl-module-file-copy \
38 perl-module-file-find \
39 perl-module-file-glob \
40 perl-module-file-path \
41 perl-module-file-spec \
42 perl-module-file-spec-unix \
43 perl-module-file-stat \
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060044 perl-module-file-temp \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060045 perl-module-getopt-long \
46 perl-module-io-file \
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060047 perl-module-list-util \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060048 perl-module-overloading \
49 perl-module-posix \
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060050 perl-module-scalar-util \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060051 perl-module-symbol \
52 perl-module-thread-queue \
53 perl-module-threads \
54 "
Patrick Williams213cb262021-08-07 19:21:33 -050055RDEPENDS:${PN}:class-native = "m4-native gnu-config-native hostperl-runtime-native"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060056
57inherit autotools texinfo
58
59PERL = "${USRBINPATH}/perl"
Patrick Williams213cb262021-08-07 19:21:33 -050060PERL:class-native = "/usr/bin/env perl"
61PERL:class-nativesdk = "/usr/bin/env perl"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060062
63CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
64
65EXTRA_OECONF += "ac_cv_path_M4=m4 ac_cv_prog_TEST_EMACS=no"
66
67# As autoconf installs its own config.* files, ensure that they're always up to date.
68update_gnu_config() {
69 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/build-aux
70 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/build-aux
71}
72do_configure[prefuncs] += "update_gnu_config"
73
Patrick Williams213cb262021-08-07 19:21:33 -050074do_configure:class-native() {
Andrew Geisslerd1e89492021-02-12 15:35:20 -060075 oe_runconf
76}
77
Patrick Williams213cb262021-08-07 19:21:33 -050078do_install:append() {
Andrew Geisslerd1e89492021-02-12 15:35:20 -060079 rm -rf ${D}${datadir}/emacs
80}
81
82BBCLASSEXTEND = "native nativesdk"