blob: e374979cb409fe5d006ea44589d72a270ee7450b [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Pure python rfc3986 validator"
2HOMEPAGE = "https://github.com/naimetti/rfc3986-validator"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6"
5
6FILESEXTRAPATHS:prepend := "${THISDIR}/python-rfc3986-validator:"
7
8SRC_URI[md5sum] = "47f7657b790aaf6011a1ab3d86c6be95"
9SRC_URI[sha256sum] = "3d44bde7921b3b9ec3ae4e3adca370438eccebc676456449b145d533b240d055"
10
11PYPI_PACKAGE = "rfc3986_validator"
12UPSTREAM_CHECK_REGEX = "/rfc3986-validator/(?P<pver>(\d+[\.\-_]*)+)/"
13
14inherit pypi setuptools3
15
Andrew Geissler87f5cff2022-09-30 13:13:31 -050016SRC_URI += "\
Andrew Geissler595f6302022-01-24 19:11:47 +000017 file://0001-setup.py-move-pytest-runner-to-test_requirements.patch \
18"
19
20RDEPENDS:${PN} += "\
21 python3-core \
22"
23
24BBCLASSEXTEND = "native nativesdk"