blob: 04c7c2a6acf9a85b7eb468aec22ebe53ba3c8008 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001BPN = "qemu"
2
3inherit python3-dir
4
5require qemu-native.inc
6
7# As some of the files installed by qemu-native and qemu-system-native
8# are the same, we depend on qemu-native to get the full installation set
9# and avoid file clashes
10DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native bison-native meson-native ninja-native"
11
12EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}"
13
Andrew Geissler615f2f12022-07-15 14:00:58 -050014PACKAGECONFIG ??= "fdt alsa kvm pie slirp \
Andrew Geissler9aee5002022-03-30 16:27:02 +000015 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virglrenderer epoxy', '', d)} \
Andrew Geisslereff27472021-10-29 15:35:00 -050016"
17
18# Handle distros such as CentOS 5 32-bit that do not have kvm support
19PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
20
21do_install:append() {
22 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
23
24 # The following is also installed by qemu-native
25 rm -f ${D}${datadir}/qemu/trace-events-all
26 rm -rf ${D}${datadir}/qemu/keymaps
27 rm -rf ${D}${datadir}/icons/
28 rm -rf ${D}${includedir}/qemu-plugin.h
29
30 # Install qmp.py to be used with testimage
Andrew Geissler87f5cff2022-09-30 13:13:31 -050031 install -d ${D}${libdir}/qemu-python/qmp/
32 install -D ${S}/python/qemu/qmp/* ${D}${libdir}/qemu-python/qmp/
Andrew Geisslereff27472021-10-29 15:35:00 -050033}