blob: 1210f73a8694dd50c26e4c93ea194eeab7cfe25e [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "OpenGL function pointer management library"
2DESCRIPTION = "It hides the complexity of dlopen(), dlsym(), \
3glXGetProcAddress(), eglGetProcAddress(), etc. from the app developer, with \
4very little knowledge needed on their part. They get to read GL specs and \
5write code using undecorated function names like glCompileShader()."
6HOMEPAGE = "https://github.com/anholt/libepoxy/"
7SECTION = "libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=58ef4c80d401e07bd9ee8b6b58cf464b"
11
Andrew Geissler87f5cff2022-09-30 13:13:31 -050012SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/${BP}.tar.xz \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 file://0001-dispatch_common.h-define-also-EGL_NO_X11.patch \
14 "
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050015SRC_URI[sha256sum] = "d168a19a6edfdd9977fef1308ccf516079856a4275cf876de688fb7927e365e4"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050016GITHUB_BASE_URI = "https://github.com/anholt/libepoxy/releases"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
Andrew Geissler87f5cff2022-09-30 13:13:31 -050018inherit meson pkgconfig features_check github-releases
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20REQUIRED_DISTRO_FEATURES = "opengl"
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
22PACKAGECONFIG[egl] = "-Degl=yes, -Degl=no, virtual/egl"
23PACKAGECONFIG[x11] = "-Dglx=yes, -Dglx=no -Dx11=false, virtual/libx11 virtual/libgl"
24PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} egl"
25
26EXTRA_OEMESON += "-Dtests=false"
27
Patrick Williams213cb262021-08-07 19:21:33 -050028PACKAGECONFIG:class-native = "egl x11"
29PACKAGECONFIG:class-nativesdk = "egl x11"
Andrew Geissler82c905d2020-04-13 13:39:40 -050030
31BBCLASSEXTEND = "native nativesdk"
32