blob: b7fdc0d399f0d818fd1a71733be5ad15a85cad55 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Liberation(tm) Fonts"
2DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \
3created by Ascender(c) which aims at metric compatibility with \
4Arial, Times New Roman, Courier New."
5HOMEPAGE = "https://github.com/liberationfonts/liberation-fonts"
6BUGTRACKER = "https://bugzilla.redhat.com/"
7
8SECTION = "x11/fonts"
9LICENSE = "OFL-1.1"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=f96db970a9a46c5369142b99f530366b"
11PE = "1"
12
13SRC_URI = "https://github.com/liberationfonts/liberation-fonts/files/7261482/liberation-fonts-ttf-${PV}.tar.gz \
14 file://30-liberation-aliases.conf"
15SRC_URI[sha256sum] = "7191c669bf38899f73a2094ed00f7b800553364f90e2637010a69c0e268f25d0"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050016GITHUB_BASE_URI = "https://github.com/liberationfonts/liberation-fonts/releases"
Andrew Geisslereff27472021-10-29 15:35:00 -050017
18S = "${WORKDIR}/liberation-fonts-ttf-${PV}"
19
Andrew Geissler87f5cff2022-09-30 13:13:31 -050020inherit allarch fontcache github-releases
Andrew Geisslereff27472021-10-29 15:35:00 -050021
22do_install () {
23 install -d ${D}${datadir}/fonts/ttf/
24 for i in *.ttf; do
25 install -m 0644 $i ${D}${prefix}/share/fonts/ttf/${i}
26 done
27
28 install -d ${D}${sysconfdir}/fonts/conf.d/
29 install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/
30
31 install -d ${D}${prefix}/share/doc/${BPN}/
32 install -m 0644 LICENSE ${D}${datadir}/doc/${BPN}/
33}
34
35PACKAGES = "${PN}"
36FILES:${PN} += "${sysconfdir} ${datadir}"
37
38BBCLASSEXTEND = "native nativesdk"