blob: 3480eb954d5b78dbbb22339b5153d1e8dc35c3f4 [file] [log] [blame]
Andrew Geissler87f5cff2022-09-30 13:13:31 -05001SUMMARY = "VirGL virtual OpenGL renderer"
2DESCRIPTION = "Virgil is a research project to investigate the possibility of \
3creating a virtual 3D GPU for use inside qemu virtual machines, that allows \
4the guest operating system to use the capabilities of the host GPU to \
5accelerate 3D rendering."
6HOMEPAGE = "https://virgil3d.github.io/"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://COPYING;md5=c81c08eeefd9418fca8f88309a76db10"
10
11DEPENDS = "libdrm libepoxy virtual/egl virtual/libgbm"
12SRCREV = "0922041ec6730122e0fec11404e6859e2efc4bc0"
13SRC_URI = "git://gitlab.freedesktop.org/virgl/virglrenderer.git;branch=master;protocol=https \
14 file://0001-meson.build-use-python3-directly-for-python.patch \
15 "
16
17S = "${WORKDIR}/git"
18
19inherit meson pkgconfig features_check
20
21PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', 'venus-experimental', '', d)}"
22
23PACKAGECONFIG[venus-experimental] = "-Dvenus-experimental=true,-Dvenus-experimental=false,vulkan-loader vulkan-headers"
24PACKAGECONFIG[va] = "-Dvideo=true,-Dvideo=false,libva"
25PACKAGECONFIG[render-server] = "-Drender-server=true,-Drender-server=false"
26PACKAGECONFIG[drm-msm-experimental] = "-Ddrm-msm-experimental=true,-Ddrm-msm-experimental=false"
27PACKAGECONFIG[minigbm_allocation] = "-Dminigbm_allocation=true,-Dminigbm_allocation=false"
28PACKAGECONFIG[venus-validate] = "-Dvenus-validate=true,-Dvenus-validate=false"
29PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,libcheck"
30
31BBCLASSEXTEND = "native nativesdk"
32
33REQUIRED_DISTRO_FEATURES = "opengl"