blob: 3fb8c6b14791c20ed8193959087c1dd423efff1a [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Hardware RNG based on CPU timing jitter"
2DESCRIPTION = "The Jitter RNG provides a noise source using the CPU execution timing jitter. \
3It does not depend on any system resource other than a high-resolution time \
4stamp. It is a small-scale, yet fast entropy source that is viable in almost \
5all environments and on a lot of CPU architectures."
6HOMEPAGE = "http://www.chronox.de/jent.html"
7LICENSE = "GPL-2.0-or-later | BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=64a87180908540620ce364b5e69b3b03 \
9 file://LICENSE.gplv2;md5=eb723b61539feef013de476e68b5c50a \
10 file://LICENSE.bsd;md5=66a5cedaf62c4b2637025f049f9b826f \
11 "
12SRC_URI = "git://github.com/smuellerDD/jitterentropy-library.git;branch=master;protocol=https"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013SRCREV = "4544e11320138ac02797af81766f4476a71bb09f"
Andrew Geissler9aee5002022-03-30 16:27:02 +000014S = "${WORKDIR}/git"
15
16# remove at next version upgrade or when output changes
17HASHEQUIV_HASH_VERSION .= ".2"
18
19do_configure[noexec] = "1"
20
21LDFLAGS += "-Wl,-O0"
22
23do_install () {
24 oe_runmake install INCDIR="/include" \
25 DESTDIR="${D}" \
26 PREFIX="${exec_prefix}" \
27 LIBDIR="${baselib}" \
28 INSTALL_STRIP="install"
29}
30