blob: 712cf0203ffde8a620e35f6ef4b24e41169ece6f [file] [log] [blame]
Andrew Geissler6ce62a22020-11-30 19:58:47 -06001SUMMARY = "Development package for building Applications that use numa"
2HOMEPAGE = "http://oss.sgi.com/projects/libnuma/"
3DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \
4to run other programs with a specific NUMA policy and a libnuma to do \
5allocations with NUMA policy in applications."
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-2.0-only & LGPL-2.1-only"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06007SECTION = "apps"
8
9inherit autotools-brokensep ptest
10
Andrew Geissler87f5cff2022-09-30 13:13:31 -050011LIC_FILES_CHKSUM = "file://README.md;beginline=19;endline=32;md5=9f34c3af4ed6f3f5df0da5f3c0835a43"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060012
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013SRCREV = "01a39cb4edc0dd0f4151b7ad11e0c56d2e612a02"
14PV = "2.0.15"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060015
Andrew Geissler595f6302022-01-24 19:11:47 +000016SRC_URI = "git://github.com/numactl/numactl;branch=master;protocol=https \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060017 file://Fix-the-test-output-format.patch \
18 file://Makefile \
19 file://run-ptest \
20 file://0001-define-run-test-target.patch \
21 "
22
23S = "${WORKDIR}/git"
24
Patrick Williams213cb262021-08-07 19:21:33 -050025LDFLAGS:append:riscv64 = " -latomic"
26LDFLAGS:append:riscv32 = " -latomic"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060027
28do_install() {
29 oe_runmake DESTDIR=${D} prefix=${D}/usr install
30 #remove the empty man2 directory
31 rm -r ${D}${mandir}/man2
32}
33
34do_compile_ptest() {
35 oe_runmake test
36}
37
38do_install_ptest() {
39 #install tests binaries
40 local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
41 mynode nodemap node-parse pagesize prefered randmap realloc_test \
42 tbitmap tshared"
43
44 [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
45 for i in $test_binaries; do
46 install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
47 done
48
49 local test_scripts="checktopology checkaffinity printcpu regress regress2 \
50 shmtest runltp bind_range"
51 for i in $test_scripts; do
52 install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
53 done
54
55 install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
56 install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
57}
58
Patrick Williams213cb262021-08-07 19:21:33 -050059RDEPENDS:${PN}-ptest = "bash"