Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "X.Org X server configuration file" |
| 2 | HOMEPAGE = "http://www.x.org" |
| 3 | SECTION = "x11/base" |
| 4 | LICENSE = "MIT-X" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 6 | PR = "r33" |
| 7 | |
| 8 | SRC_URI = "file://xorg.conf" |
| 9 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 10 | S = "${WORKDIR}" |
| 11 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 12 | CONFFILES:${PN} = "${sysconfdir}/X11/xorg.conf" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | |
| 14 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 15 | ALLOW_EMPTY:${PN} = "1" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 16 | |
| 17 | do_install () { |
| 18 | if test -s ${WORKDIR}/xorg.conf; then |
| 19 | install -d ${D}/${sysconfdir}/X11 |
| 20 | install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/ |
| 21 | fi |
| 22 | } |