blob: ff2b7d893baed4615f991fd57ad9388bab75ef42 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Audio decoder for MPEG-1 Layer 1/2/3"
2DESCRIPTION = "The core of mpg123 is an MPEG-1 Layer 1/2/3 decoding library, which can be used by other programs. \
3mpg123 also comes with a command-line tool which can playback using ALSA, PulseAudio, OSS, and several other APIs, \
4and also can write the decoded audio to WAV."
5HOMEPAGE = "http://mpg123.de/"
6BUGTRACKER = "http://sourceforge.net/p/mpg123/bugs/"
7SECTION = "multimedia"
8
9LICENSE = "LGPLv2.1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040010LIC_FILES_CHKSUM = "file://COPYING;md5=1e86753638d3cf2512528b99079bc4f3"
11
12SRC_URI = "https://www.mpg123.de/download/${BP}.tar.bz2"
13SRC_URI[md5sum] = "ea32caa61d41d8be797f0b04a1b43ad9"
14SRC_URI[sha256sum] = "6c1337aee2e4bf993299851c70b7db11faec785303cfca3a5c3eb5f329ba7023"
15
16inherit autotools pkgconfig
17
18# The options should be mutually exclusive for configuration script.
19# If both alsa and pulseaudio are specified (as in the default distro features)
20# pulseaudio takes precedence.
21PACKAGECONFIG_ALSA = "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}"
22PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '${PACKAGECONFIG_ALSA}', d)}"
23
24PACKAGECONFIG[alsa] = "--with-default-audio=alsa,,alsa-lib"
25PACKAGECONFIG[esd] = ",,esound"
26PACKAGECONFIG[jack] = ",,jack"
27PACKAGECONFIG[openal] = ",,openal-soft"
28PACKAGECONFIG[portaudio] = ",,portaudio-v19"
29PACKAGECONFIG[pulseaudio] = "--with-default-audio=pulse,,pulseaudio"
30PACKAGECONFIG[sdl] = ",,libsdl"
31
32# Following are possible sound output modules:
33# alsa arts coreaudio dummy esd jack nas openal os2 oss portaudio pulse sdl sndio sun tinyalsa win32 win32_wasapi
34AUDIOMODS += "${@bb.utils.filter('PACKAGECONFIG', 'alsa esd jack openal portaudio sdl', d)}"
35AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'pulse', '', d)}"
36
37EXTRA_OECONF = " \
38 --enable-shared \
39 --with-audio='${AUDIOMODS}' \
40 ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-cpu=neon', '', d)} \
41 ${@bb.utils.contains('TUNE_FEATURES', 'altivec', '--with-cpu=altivec', '', d)} \
42"
43# Fails to build with thumb-1 (qemuarm)
44#| {standard input}: Assembler messages:
45#| {standard input}:47: Error: selected processor does not support Thumb mode `smull r5,r6,r7,r4'
46#| {standard input}:48: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r5,r5,lsr#24'
47#...
48#| make[3]: *** [equalizer.lo] Error 1
49ARM_INSTRUCTION_SET_armv4 = "arm"
50ARM_INSTRUCTION_SET_armv5 = "arm"