blob: 29e01cc23d33383dc388a6ad76b0209312869950 [file] [log] [blame]
Brad Bishop23eaf032019-11-20 05:15:02 -05001SUMMARY = "Evince is a document viewer for document formats like pdf, ps, djvu"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=96f2f8d5ee576a2163977938ea36fa7b"
4SECTION = "x11/office"
5DEPENDS = " \
6 gnome-common-native \
7 yelp-tools-native \
8 appstream-glib \
9 gtk+3 \
10 gspell \
11 libsecret \
12 poppler \
13 gstreamer1.0-plugins-base \
14 orc \
15 adwaita-icon-theme \
16 ${@bb.utils.contains('DISTRO_FEATURES','x11','gnome-desktop3','',d)} \
17"
18
Andrew Geissler89770b02020-06-13 10:40:47 -050019GNOMEBASEBUILDCLASS = "meson"
Brad Bishop23eaf032019-11-20 05:15:02 -050020
Andrew Geissler89770b02020-06-13 10:40:47 -050021inherit gnomebase itstool gnome-help pkgconfig gsettings gobject-introspection upstream-version-is-even gettext mime-xdg gtk-doc
22
23SRC_URI[archive.md5sum] = "9762dabdde37a804072bccbfd311d357"
24SRC_URI[archive.sha256sum] = "af2ebdf7f74e6580c4f1a12bdfe26b9ff90374d7acae061de0666d64012a9db2"
Brad Bishop23eaf032019-11-20 05:15:02 -050025SRC_URI += " \
26 file://0001-Add-format-attribute-to-_synctex_malloc.patch \
27 file://0002-add-a-formatting-attribute-check.patch \
28"
29
Andrew Geissler89770b02020-06-13 10:40:47 -050030GTKDOC_MESON_OPTION = "gtk_doc"
31
32EXTRA_OEMESON = " \
33 -Dsystemduserunitdir=no \
Brad Bishop23eaf032019-11-20 05:15:02 -050034"
35
36do_compile_prepend() {
37 export GIR_EXTRA_LIBS_PATH="${B}/libdocument/.libs"
38}
39
40PACKAGECONFIG ??= ""
Andrew Geissler89770b02020-06-13 10:40:47 -050041PACKAGECONFIG[nautilus] = "-Dnautilus=true,-Dnautilus=false,nautilus"
42PACKAGECONFIG[browser-plugin] = "-Dbrowser_plugin=true,-Dbrowser_plugin=false"
Brad Bishop23eaf032019-11-20 05:15:02 -050043
44RDEPENDS_${PN} += "glib-2.0-utils"
45RRECOMMMENDS_${PN} = "adwaita-icon-theme"
46
47PACKAGES =+ "${PN}-nautilus-extension"
48PACKAGES =+ "${PN}-browser-plugin"
49
50FILES_${PN} += "${datadir}/dbus-1 \
51 ${datadir}/metainfo \
52 ${datadir}/thumbnailers \
53"
54FILES_${PN}-nautilus-extension = "${libdir}/nautilus/*/*so"
55FILES_${PN}-browser-plugin = "${libdir}/mozilla/*/*so"