blob: d3673a1fd9b4bf0bfaaf72fa3c9d90f1fc4a1892 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNOME Settings"
2DESCRIPTION = "GNOME Settings is GNOME's main interface for configuration of various aspects of your desktop"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e"
5
6GNOMEBASEBUILDCLASS = "meson"
7
8inherit gnomebase gsettings gettext vala upstream-version-is-even bash-completion features_check
9
10DEPENDS = " \
11 gdk-pixbuf-native \
12 colord-gtk \
13 udisks2 \
14 upower \
15 polkit \
16 pulseaudio \
17 accountsservice \
18 samba \
19 gsettings-desktop-schemas \
20 gnome-settings-daemon \
21 gnome-desktop3 \
22 gnome-online-accounts \
23 libnma \
24 gnome-bluetooth \
25 grilo \
26 libgtop \
27 gsound \
28 libpwquality \
29"
30
31REQUIRED_DISTRO_FEATURES += "polkit pulseaudio systemd x11"
32
Andrew Geissler89770b02020-06-13 10:40:47 -050033SRC_URI[archive.md5sum] = "45832b7217c8d5fa5e2dbc214972c12d"
34SRC_URI[archive.sha256sum] = "e0a5eff0c6d6c22db0c54fd070460de874d367ef3f9072e1559b70f28b847817"
Andrew Geissler82c905d2020-04-13 13:39:40 -050035SRC_URI += "file://0001-Add-meson-option-to-pass-sysroot.patch"
36
37PACKAGECONFIG ??= "ibus ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}"
38PACKAGECONFIG[ibus] = "-Dibus=true, -Dibus=false, ibus"
39PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false, wayland"
40
41# Once we have (lib)cheese we can make cheese a PACKAGECONFIG
42EXTRA_OEMESON = " \
43 -Doe_sysroot=${STAGING_DIR_HOST} \
44 -Dcheese=false \
45"
46
47FILES_${PN} += " \
48 ${datadir}/dbus-1 \
49 ${datadir}/gnome-shell \
50 ${datadir}/metainfo \
51"
52
53FILES_${PN}-dev += "${datadir}/gettext"
54
55RDEPENDS_${PN} += "gsettings-desktop-schemas"