blob: a9f5274092da38a34f2f1f9b265181358f676f6e [file] [log] [blame]
Brad Bishop23eaf032019-11-20 05:15:02 -05001SUMMARY = "Window navigation construction toolkit"
2LICENSE = "LGPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
4
5GNOMEBASEBUILDCLASS = "meson"
6
Brad Bishop8410d612019-11-25 09:40:59 -05007inherit gnomebase gsettings gobject-introspection gettext features_check upstream-version-is-even
Brad Bishop23eaf032019-11-20 05:15:02 -05008
9SRC_URI[archive.md5sum] = "528b0b7cc2dd22c6026a9c8739c71fa7"
10SRC_URI[archive.sha256sum] = "7ce4979817866911a94ecb75b36db56797e038c0c524c5c1a81aefccafc17337"
11
12DEPENDS = " \
13 colord \
14 geocode-glib \
15 gcr \
16 gnome-desktop3 \
17 libgweather \
18 lcms \
19 libcanberra \
20 geoclue \
21 libnotify \
22 upower \
23 libwacom \
24 virtual/libx11 \
25"
26
27# all these are mandatory
28REQUIRED_DISTRO_FEATURES = "x11 polkit pulseaudio systemd gobject-introspection-data"
29UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
30
Andrew Geissler89770b02020-06-13 10:40:47 -050031SRC_URI[archive.md5sum] = "102dc488a6a726e4050cf5ab7e967e8d"
32SRC_URI[archive.sha256sum] = "3e33dbd319b562a5ab602dcab6de3ca81b85f8346672e90ec632b36bbf15ee4b"
Brad Bishop23eaf032019-11-20 05:15:02 -050033
34# allow cross build mixed with build of native tools
35do_write_config_append() {
36 cat >${WORKDIR}/meson.native <<EOF
37[binaries]
38pkgconfig = 'pkg-config-native'
39EOF
40}
41EXTRA_OEMESON = "--native-file ${WORKDIR}/meson.native"
42
43PACKAGECONFIG ??= " \
44 cups nm \
45 alsa gudev \
46 ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)} \
47"
48PACKAGECONFIG[alsa] = "-Dalsa=true,-Dalsa=false,alsa-lib"
49PACKAGECONFIG[cups] = "-Dcups=true,-Dcups=false,cups"
50PACKAGECONFIG[gudev] = "-Dgudev=true,-Dgudev=false,libgudev"
51PACKAGECONFIG[nm] = "-Dnetwork_manager=true,-Dnetwork_manager=false,networkmanager"
52PACKAGECONFIG[wayland] = "-Dwayland=true,-Dwayland=false,wayland"
53
54FILES_${PN} += " \
55 ${systemd_user_unitdir} \
56 ${libdir}/gnome-settings-daemon-3.0/libgsd.so \
57"
58
59RDEPEND_${PN} += "gdbus"