blob: 6020c203534cbb5fbf3efa957c7353a5d4a0def2 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "Video player and streamer - davinci edition"
2HOMEPAGE = "http://www.videolan.org"
3SECTION = "multimedia"
4
5LICENSE = "GPL-2.0"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8DEPENDS = "coreutils-native fribidi libtool libgcrypt libgcrypt-native \
9 dbus libxml2 gnutls \
10 tremor faad2 ffmpeg flac alsa-lib \
11 lua-native lua libidn \
12 avahi jpeg xz libmodplug mpeg2dec \
13 libmtp libopus orc libsamplerate0 libusb1 schroedinger taglib \
14 tiff"
15
16LDFLAGS_append_riscv64 = " -latomic"
17
18# While this item does not require it, it depends on ffmpeg which does
19LICENSE_FLAGS = "commercial"
20
21SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz \
Andrew Geissler89770b02020-06-13 10:40:47 -050022 file://0001-make-opencv-configurable.patch \
23 file://0002-use-vorbisidec.patch \
24 file://0003-fix-luaL-checkint.patch \
25 file://0004-Use-packageconfig-to-detect-mmal-support.patch \
26 file://0005-Fix-build-with-Qt-5.15.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050027"
Andrew Geissler89770b02020-06-13 10:40:47 -050028SRC_URI[sha256sum] = "a966abfc7f3b2ff3adaa130306ecaf5d6ad3b6dc73385fc9ab0c1204029d4c31"
Andrew Geissler82c905d2020-04-13 13:39:40 -050029
30inherit autotools features_check gettext pkgconfig mime-xdg
31
32REQUIRED_DISTRO_FEATURES = "x11"
33
34export BUILDCC = "${BUILD_CC}"
35EXTRA_OECONF = "\
36 --enable-run-as-root \
37 --enable-xvideo \
38 --disable-screen --disable-caca \
39 --enable-vlm \
40 --enable-freetype \
41 --enable-tremor \
42 --enable-v4l2 --disable-aa --disable-faad \
43 --enable-dbus \
44 --without-contrib \
45 --without-kde-solid \
46 --enable-realrtsp \
47 --disable-libtar \
48 --enable-avcodec \
49 ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/moc \
50 ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/rcc \
51 ac_cv_path_UIC=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/uic \
52"
53
54PACKAGECONFIG ?= " \
55 live555 dc1394 dv1394 notify fontconfig fluidsynth freetype dvdread png \
56 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
57 x264 \
58"
59
60inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'qmake5_paths', '', d)}
61
62PACKAGECONFIG[mmal] = "--enable-omxil --enable-omxil-vout --enable-rpi-omxil --enable-mmal,,userland"
63PACKAGECONFIG[x264] = "--enable-x264,--disable-x264,x264"
64PACKAGECONFIG[fluidsynth] = ",,fluidsynth"
65PACKAGECONFIG[mad] = "--enable-mad,--disable-mad,libmad"
66PACKAGECONFIG[a52] = "--enable-a52,--disable-a52,liba52"
67PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
68PACKAGECONFIG[live555] = "--enable-live555 LIVE555_PREFIX=${STAGING_DIR_HOST}${prefix},--disable-live555,live555"
69PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass"
70PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc,libpostproc"
71PACKAGECONFIG[libva] = "--enable-libva,--disable-libva,libva"
72PACKAGECONFIG[opencv] = "--enable-opencv,--disable-opencv,opencv"
73PACKAGECONFIG[speex] = "--enable-speex,--disable-speex,speex"
74PACKAGECONFIG[gstreamer] = "--enable-gst-decode,--disable-gst-decode,gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
75PACKAGECONFIG[vpx] = "--enable-vpx,--disable-vpx, libvpx"
76PACKAGECONFIG[qt5] = "--enable-qt,--disable-qt, qtbase-native qtx11extras qtsvg"
77PACKAGECONFIG[freerdp] = "--enable-freerdp,--disable-freerdp, freerdp"
78PACKAGECONFIG[dvbpsi] = "--enable-dvbpsi,--disable-dvbpsi, libdvbpsi"
79PACKAGECONFIG[samba] = "--enable-smbclient,--disable-smbclient, samba"
80PACKAGECONFIG[upnp] = "--enable-upnp,--disable-upnp,libupnp"
81PACKAGECONFIG[dvdnav] = "--enable-dvdnav,--disable-dvdnav,libdvdnav libdvdcss"
82PACKAGECONFIG[sftp] = "--enable-sftp,--disable-sftp,libssh2"
83PACKAGECONFIG[vorbis] = "--enable-vorbis,--disable-vorbis,libvorbis libogg"
84PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libvorbis libogg"
85PACKAGECONFIG[dc1394] = "--enable-dc1394,--disable-dc1394,libdc1394"
86PACKAGECONFIG[dv1394] = "--enable-dv1394,--disable-dv1394,libraw1394 libavc1394"
87PACKAGECONFIG[svg] = "--enable-svg,--disable-svg,librsvg"
88PACKAGECONFIG[svgdec] = "--enable-svgdec,--disable-svgdec,librsvg cairo"
89PACKAGECONFIG[notify] = "--enable-notify,--disable-notify, libnotify gtk+3"
90PACKAGECONFIG[fontconfig] = "--enable-fontconfig,--disable-fontconfig, fontconfig"
91PACKAGECONFIG[freetype] = "--enable-freetype,--disable-freetype, freetype"
92PACKAGECONFIG[dvdread] = "--enable-dvdread,--disable-dvdread, libdvdread libdvdcss"
93PACKAGECONFIG[vnc] = "--enable-vnc,--disable-vnc, libvncserver"
94PACKAGECONFIG[x11] = "--with-x --enable-xcb,--without-x --disable-xcb, xcb-util-keysyms libxpm libxinerama"
95PACKAGECONFIG[png] = "--enable-png,--disable-png,libpng"
96PACKAGECONFIG[vdpau] = "--enable-vdpau,--disable-vdpau,libvdpau"
97PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland wayland-native"
98
99do_configure_append() {
100 sed -i -e s:'${top_builddir_slash}libtool':'${top_builddir_slash}'${TARGET_SYS}-libtool:g ${B}/doltlibtool
101
102 # moc needs support: precreate build paths
103 for qtpath in adapters components/epg components/playlist components/sout dialogs managers styles util/buttons; do
104 mkdir -p "${B}/modules/gui/qt/$qtpath"
105 done
106}
107
108# This recipe packages vlc as a library as well, so qt4 dependencies
109# can be avoided when only the library is installed.
110PACKAGES =+ "libvlc"
111
112LEAD_SONAME_libvlc = "libvlc.so.5"
113FILES_libvlc = "${libdir}/lib*.so.*"
114
115FILES_${PN} += "\
116 ${bindir}/vlc \
117 ${libdir}/vlc/vlc/libvlc_vdpau.so \
118 ${datadir}/applications \
119 ${datadir}/vlc/ \
120 ${datadir}/icons \
121 ${datadir}/metainfo/vlc.appdata.xml \
122"
123
124FILES_${PN}-dbg += "\
125 ${libdir}/vlc/*/.debug \
126 ${libdir}/vlc/plugins/*/.debug \
127"
128
129FILES_${PN}-staticdev += "\
130 ${libdir}/vlc/plugins/*/*.a \
131"
132
133INSANE_SKIP_${PN} = "dev-so"
134