blob: 8d82ee45469d32c17e98d4bc56388c853632fcf7 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "A a package of utilities for doing and managing mounts of the Linux CIFS filesystem."
2HOMEPAGE = "http://wiki.samba.org/index.php/LinuxCIFS_utils"
3SECTION = "otherosfs"
4LICENSE = "GPLv3 & LGPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7PV = "6.10"
8
9SRCREV = "5ff5fc2ecc10353fd39ad508db5c2828fd2d8d9a"
10SRC_URI = "git://git.samba.org/cifs-utils.git"
11
12S = "${WORKDIR}/git"
13DEPENDS += "libtalloc"
14
15PACKAGECONFIG ??= ""
16PACKAGECONFIG[cap] = "--with-libcap,--without-libcap,libcap"
17# when enabled, it creates ${bindir}/cifscreds and --ignore-fail-on-non-empty in do_install_append is needed
18PACKAGECONFIG[cifscreds] = "--enable-cifscreds,--disable-cifscreds,keyutils"
19# when enabled, it creates ${sbindir}/cifs.upcall and --ignore-fail-on-non-empty in do_install_append is needed
20PACKAGECONFIG[cifsupcall] = "--enable-cifsupcall,--disable-cifsupcall,krb5 libtalloc keyutils"
21PACKAGECONFIG[cifsidmap] = "--enable-cifsidmap,--disable-cifsidmap,keyutils samba"
22PACKAGECONFIG[cifsacl] = "--enable-cifsacl,--disable-cifsacl,samba"
23PACKAGECONFIG[pam] = "--enable-pam --with-pamdir=${base_libdir}/security,--disable-pam,libpam keyutils"
24
25SRC_URI += " \
26 file://0001-Bugfix-Modify-the-dir-of-install-exec-hook-and.patch \
27 "
28
29inherit autotools pkgconfig
30
31do_install_append() {
32 # Remove empty /usr/bin and /usr/sbin directories since the mount helper
33 # is installed to /sbin
34 rmdir --ignore-fail-on-non-empty ${D}${bindir} ${D}${sbindir}
35}
36
37FILES_${PN} += "${base_libdir}/security"
38FILES_${PN}-dbg += "${base_libdir}/security/.debug"
39RRECOMMENDS_${PN} = "kernel-module-cifs"