blob: 387dd67123a7c4d6647ef5630e1d3390266b5bff [file] [log] [blame]
Brad Bishop996bc452019-12-02 13:05:15 -05001require ${BPN}.inc
2
Andrew Geissler82c905d2020-04-13 13:39:40 -05003SRC_URI += "file://${BPN}.initd \
4 file://0001-Remove-modules_clean-from-clean-target.patch \
5 "
Brad Bishop996bc452019-12-02 13:05:15 -05006
7SRC_URI_append_libc-musl = " file://Drop-use-of-error-h.patch"
8
9inherit update-rc.d
10
11INITSCRIPT_NAME = "${BPN}"
12
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
14
Brad Bishop996bc452019-12-02 13:05:15 -050015do_compile() {
16 oe_runmake nbcat
17 oe_runmake mkemlog
18}
19
20do_install() {
21 install -Dm 0755 ${WORKDIR}/${BPN}.initd ${D}${sysconfdir}/init.d/${BPN}
22 install -Dm 0755 ${S}/nbcat ${D}${bindir}/nbcat
23 install -Dm 0755 ${S}/mkemlog ${D}${bindir}/mkemlog
24}
25
Brad Bishope42b3e32020-01-15 22:08:42 -050026RRECOMMENDS_${PN} += "kernel-module-emlog"