blob: 21d13ac93536d70e8276e21cf788c6f96896d94c [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Fast Log processor and Forwarder"
2DESCRIPTION = "Fluent Bit is a data collector, processor and \
3forwarder for Linux. It supports several input sources and \
4backends (destinations) for your data. \
5"
6
7HOMEPAGE = "http://fluentbit.io"
8BUGTRACKER = "https://github.com/fluent/fluent-bit/issues"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
12SECTION = "net"
13
14SRC_URI = "http://fluentbit.io/releases/1.3/fluent-bit-${PV}.tar.gz \
15 file://jemalloc.patch \
16 file://cross-build-init-system-detection.patch \
17 file://builtin-nan.patch \
Brad Bishop0e2770c2020-01-21 07:31:46 -050018 file://0001-ppc-Fix-signature-for-co_create-API.patch \
Brad Bishope42b3e32020-01-15 22:08:42 -050019 "
20SRC_URI[md5sum] = "6eae6dfd0a874e5dd270c36e9c68f747"
21SRC_URI[sha256sum] = "e037c76c89269c8dc4027a08e442fefd2751b0f1e0f9c38f9a4b12d781a9c789"
22
23S = "${WORKDIR}/fluent-bit-${PV}"
24DEPENDS = "zlib bison-native flex-native"
25DEPENDS_append_libc-musl = " fts "
26
27INSANE_SKIP_${PN}-dev += "dev-elf"
28
29# Use CMake 'Unix Makefiles' generator
30OECMAKE_GENERATOR ?= "Unix Makefiles"
31
32# Fluent Bit build options
33# ========================
34
35# Host related setup
36EXTRA_OECMAKE += "-DGNU_HOST=${HOST_SYS} -DFLB_ALL=ON -DFLB_TD=1"
37
38# Disable LuaJIT and filter_lua support
39EXTRA_OECMAKE += "-DFLB_LUAJIT=Off -DFLB_FILTER_LUA=Off "
40
41# Disable Library and examples
42EXTRA_OECMAKE += "-DFLB_SHARED_LIB=Off -DFLB_EXAMPLES=Off "
43
44EXTRA_OECMAKE += "${@bb.utils.contains('DISTRO_FEATURES','systemd','-DFLB_SYSTEMD=On','',d)}"
45
Andrew Geissler82c905d2020-04-13 13:39:40 -050046EXTRA_OECMAKE_append_riscv64 = " -DFLB_DEPS='atomic'"
47
Brad Bishope42b3e32020-01-15 22:08:42 -050048# Kafka Output plugin (disabled by default): note that when
49# enabling Kafka output plugin, the backend library librdkafka
50# requires 'openssl' as a dependency.
51#
52# DEPENDS += "openssl "
53# EXTRA_OECMAKE += "-DFLB_OUT_KAFKA=On "
54
Andrew Geissler89770b02020-06-13 10:40:47 -050055inherit cmake systemd
Brad Bishope42b3e32020-01-15 22:08:42 -050056
57SYSTEMD_SERVICE_${PN} = "td-agent-bit.service"
58TARGET_CC_ARCH_append = " ${SELECTED_OPTIMIZATION}"