blob: 23d0cf2181b7528da7162eb52a31bb456e1e64a8 [file] [log] [blame]
Andrew Geissler89770b02020-06-13 10:40:47 -05001SUMMARY = "Python decorator utilities"
2DESCRIPTION = "\
3The aim of the decorator module it to simplify the usage of decorators \
4for the average programmer, and to popularize decorators by showing \
5various non-trivial examples. Of course, as all techniques, decorators \
6can be abused and you should not try to solve every problem with a \
7decorator, just because you can."
8
9LICENSE = "BSD-2-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=be2fd2007972bf96c08af3293d728b22"
11
12SRC_URI[md5sum] = "d83c624cce93e6bdfab144821b526e1d"
13SRC_URI[sha256sum] = "e3a62f0520172440ca0dcc823749319382e377f37f140a0b99ef45fecb84bfe7"
14
15inherit pypi setuptools3
16
17RDEPENDS_${PN} += "\
18 ${PYTHON_PN}-stringold \
19 "