blob: 0a3b7734cf901078f1ce8ffc9eee36dc129e0dea [file] [log] [blame]
Andrew Geissler89770b02020-06-13 10:40:47 -05001SUMMARY = "A port of Ruby on Rails' inflection to Python."
2HOMEPAGE = "https://pypi.org/project/inflection"
3LICENSE = "MIT"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2fb6fa1a6f1792d78de19ad1bb653c31"
6
7SRC_URI[md5sum] = "87b2ab6ffdd6e15aa31d109ce5ff10bb"
8SRC_URI[sha256sum] = "f576e85132d34f5bf7df5183c2c6f94cfb32e528f53065345cf71329ba0b8924"
9
10inherit pypi setuptools3 ptest
11
12SRC_URI +=" \
13 file://run-ptest \
14"
15
16RDEPENDS_${PN}_ptest +=" \
17 ${PYTHON_PN}_pytest \
18"
19
20do_install_ptest() {
21 cp -f ${S}/test_inflection.py ${D}${PTEST_PATH}/
22}
23
24
25RDEPENDS_${PN} += "${PYTHON_PN}-pytest"
26
27BBCLASSEXTEND = "native nativesdk"