blob: fe27e8e505cd798962dddc9aa744bb454f1d5d9d [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "A generic, spec-compliant, thorough implementation of the OAuth request-signing logic"
2HOMEPAGE = "https://github.com/idan/oauthlib"
3
Brad Bishop2d39a062019-10-28 08:33:36 -04004LICENSE = "BSD-3-Clause"
Andrew Geissler89770b02020-06-13 10:40:47 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=abd2675e944a2011aed7e505290ba482"
Brad Bishop316dfdd2018-06-25 12:45:53 -04006
Andrew Geissler89770b02020-06-13 10:40:47 -05007SRC_URI[md5sum] = "43cb2b5bac983712ee55076b61181cc2"
8SRC_URI[sha256sum] = "bee41cc35fcca6e988463cacc3bcb8a96224f470ca547e697b604cc697b2f889"
Brad Bishop316dfdd2018-06-25 12:45:53 -04009
Andrew Geissler89770b02020-06-13 10:40:47 -050010inherit pypi setuptools3
Brad Bishop316dfdd2018-06-25 12:45:53 -040011
12# The following configs & dependencies are from setuptools extras_require.
13# These dependencies are optional, hence can be controlled via PACKAGECONFIG.
14# The upstream names may not correspond exactly to bitbake package names.
15#
16# Uncomment this line to enable all the optional features.
17#PACKAGECONFIG ?= "test signedtoken signals rsa"
18PACKAGECONFIG[test] = ",,,${PYTHON_PN}-blinker ${PYTHON_PN}-cryptography ${PYTHON_PN}-nose ${PYTHON_PN}-pyjwt"
19PACKAGECONFIG[signedtoken] = ",,,${PYTHON_PN}-cryptography ${PYTHON_PN}-pyjwt"
20PACKAGECONFIG[signals] = ",,,${PYTHON_PN}-blinker"
21PACKAGECONFIG[rsa] = ",,,${PYTHON_PN}-cryptography"
22
23RDEPENDS_${PN} += "${PYTHON_PN}-core ${PYTHON_PN}-crypt ${PYTHON_PN}-datetime ${PYTHON_PN}-json ${PYTHON_PN}-logging ${PYTHON_PN}-math ${PYTHON_PN}-netclient ${PYTHON_PN}-unittest"