blob: 626af05542c2edb73427208673b1ee936481c305 [file] [log] [blame]
Andrew Geissler89770b02020-06-13 10:40:47 -05001SUMMARY = "Physical quantities module"
2DESCRIPTION = "Physical quantities Python module"
3HOMEPAGE = "https://github.com/hgrecco/pint"
4SECTION = "devel/python"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
8
9PYPI_PACKAGE := "Pint"
10
11inherit pypi ptest setuptools3
12
13SRC_URI[md5sum] = "0af699bc0ccdff56228b4a81216b4f7d"
14SRC_URI[sha256sum] = "dc899061f9dc478e0aac3b0d872ca33d120efd32c382984818adab3522b6c793"
15
16DEPENDS += "python3-setuptools-scm-native"
17
18BBCLASSEXTEND = "native nativesdk"
19
20SRC_URI += " \
21 file://run-ptest \
22"
23
24RDEPENDS_${PN}-ptest += " \
25 ${PYTHON_PN}-pytest \
26"
27
28do_install_ptest() {
29 install -d ${D}${PTEST_PATH}/testsuite
30 cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
31}