blob: d3e0365ca1d06ea82e662ea161bd09dbc135bfbe [file] [log] [blame]
Andrew Geissler89770b02020-06-13 10:40:47 -05001SUMMARY = "Plugin and hook calling mechanisms for python"
2HOMEPAGE = "https://github.com/pytest-dev/pluggy"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1c8206d16fd5cc02fa9b0bb98955e5c2"
5
6SRC_URI[md5sum] = "7f610e28b8b34487336b585a3dfb803d"
7SRC_URI[sha256sum] = "15b2acde666561e1298d71b523007ed7364de07029219b604cf808bfa1c765b0"
8
9DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
10RDEPENDS_${PN} += "${PYTHON_PN}-importlib-metadata \
11 ${PYTHON_PN}-more-itertools \
12"
13
14inherit pypi ptest setuptools3
15
16SRC_URI += " \
17 file://run-ptest \
18"
19
20RDEPENDS_${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/testing
26 cp -rf ${S}/testing/* ${D}${PTEST_PATH}/testing/
27}