blob: 18f3390619abf68bc79b8cb1f10ace654c595241 [file] [log] [blame]
Andrew Geissler89770b02020-06-13 10:40:47 -05001SUMMARY = "Python library for displaying tabular data in a ASCII table format"
2HOMEPAGE = "http://code.google.com/p/prettytable"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3e73500ffa52de5071cff65990055282"
Brad Bishop5f78ea12019-09-10 07:20:03 -04005
Andrew Geissler89770b02020-06-13 10:40:47 -05006SRC_URI[md5sum] = "a6b80afeef286ce66733d54a0296b13b"
7SRC_URI[sha256sum] = "2d5460dc9db74a32bcc8f9f67de68b2c4f4d2f01fa3bd518764c69156d9cacd9"
8
9do_install_append() {
10 perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
11 for f in $perm_files; do
12 chmod 644 "${f}"
13 done
14}
15
16UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/PrettyTable/"
17UPSTREAM_CHECK_REGEX = "/PrettyTable/(?P<pver>(\d+[\.\-_]*)+)"
18
19BBCLASSEXTEND = "native nativesdk"
20inherit pypi ptest setuptools3
21
22SRC_URI += " \
23 file://run-ptest \
24"
25
26RDEPENDS_${PN} += " \
27 ${PYTHON_PN}-math \
28 ${PYTHON_PN}-html \
29"
30
31RDEPENDS_${PN}-ptest += " \
32 ${PYTHON_PN}-pytest \
33"
34
35do_install_ptest() {
36 cp -f ${S}/prettytable_test.py ${D}${PTEST_PATH}/
37}