blob: db6b5674447c09953c4c1ac1b608460ad039cb69 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
2DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \
3By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \
4polling, WebSockets, and other applications that require a long-lived connection to each user."
5HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
6LICENSE = "Apache-2.0"
Andrew Geissler89770b02020-06-13 10:40:47 -05007LIC_FILES_CHKSUM = "file://LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008
Andrew Geissler89770b02020-06-13 10:40:47 -05009SRC_URI[md5sum] = "cf39425f3d7eba9a54287f3e795a2f23"
10SRC_URI[sha256sum] = "0fe2d45ba43b00a41cd73f8be321a44936dc1aba233dee979f17a042b83eb6dc"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
Andrew Geissler89770b02020-06-13 10:40:47 -050012inherit pypi setuptools3
13
14# Requires _compression which is currently located in misc
Brad Bishop316dfdd2018-06-25 12:45:53 -040015RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-numbers ${PYTHON_PN}-email \
16 ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi ${PYTHON_PN}-threading \
Andrew Geissler89770b02020-06-13 10:40:47 -050017 ${PYTHON_PN}-ctypes ${PYTHON_PN}-misc"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018
19RDEPENDS_${PN}-test += "${PN} ${PYTHON_PN}-unittest"
20
21PACKAGES =+ "\
22 ${PN}-test \
23"
24
25FILES_${PN}-test = " \
26 ${libdir}/${PYTHON_DIR}/site-packages/*/test \
27 ${libdir}/${PYTHON_DIR}/site-packages/*/testing.py* \
28"