blob: b950d6f632b32ac29d4098d2a4b65eae252807aa [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Simple Python module for working with HTML/CSS color definitions."
2LICENSE = "BSD-3-Clause"
Andrew Geissler2ee498a2020-05-29 15:52:06 -05003LIC_FILES_CHKSUM = "file://LICENSE;md5=25b90379a52351261c51272e7923d240"
Andrew Geissler82c905d2020-04-13 13:39:40 -05004
Andrew Geissler2ee498a2020-05-29 15:52:06 -05005SRC_URI[md5sum] = "54d28a7c80b3e4d974ec2fee86768be9"
6SRC_URI[sha256sum] = "76f360636957d1c976db7466bc71dcb713bb95ac8911944dffc55c01cb516de6"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
8inherit pypi setuptools3 ptest
9
10RDEPENDS_${PN}_class-target = "\
11 ${PYTHON_PN}-stringold \
Andrew Geissler89770b02020-06-13 10:40:47 -050012 ${PYTHON_PN}-typing \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013"
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS_${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28BBCLASSEXTEND = "native nativesdk"