blob: 1e9fdd66fa563f9cbb9bdc9ce56b2310f3e4a43f [file] [log] [blame]
Alexander Filippov89bd3842019-05-22 11:07:30 +03001SUMMARY = "Init BMC Hostname"
2DESCRIPTION = "Setup BMC Unique hostname"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
6
7inherit allarch systemd
8
9RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}"
10
11SYSTEMD_SERVICE_${PN} = "first-boot-set-hostname.service"
12
13SRC_URI = "file://${PN}.sh file://${PN}.service"
14
15S = "${WORKDIR}"
16do_install() {
17 sed "s/{MACHINE}/${MACHINE}/" -i ${PN}.sh
18 install -d ${D}${bindir} ${D}${systemd_system_unitdir}
19 install ${PN}.sh ${D}${bindir}/
20 install -m 644 ${PN}.service ${D}${systemd_system_unitdir}/
21}
22