blob: 91c3db93068e162213687ab0bd82983cda4ec034 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Gummiboot is a simple UEFI boot manager which executes configured EFI images."
2HOMEPAGE = "http://freedesktop.org/wiki/Software/gummiboot"
3
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
6
7DEPENDS = "gnu-efi util-linux"
8
9inherit autotools pkgconfig
10inherit deploy
11
12PV = "48+git${SRCPV}"
13SRCREV = "2bcd919c681c952eb867ef1bdb458f1bc49c2d55"
14SRC_URI = "git://anongit.freedesktop.org/gummiboot \
15 file://fix-objcopy.patch \
16 "
17
18# Note: Add COMPATIBLE_HOST here is only because it depends on gnu-efi
19# which has set the COMPATIBLE_HOST, the gummiboot itself may work on
20# more hosts.
21COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
22
23S = "${WORKDIR}/git"
24
25EXTRA_OECONF = "--disable-manpages --with-efi-includedir=${STAGING_INCDIR} \
26 --with-efi-ldsdir=${STAGING_LIBDIR} \
27 --with-efi-libdir=${STAGING_LIBDIR}"
28
29EXTRA_OEMAKE += "gummibootlibdir=${libdir}/gummiboot"
30
31do_deploy () {
32 install ${B}/gummiboot*.efi ${DEPLOYDIR}
33}
34addtask deploy before do_build after do_compile