blob: ade72f4b7198044a7aad6edee79206d992d97c15 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001require busybox.inc
2
3SRCREV = "be947c4d97c0dacb703a6f24dd813ff6dd3a33b6"
4# Lookout for PV bump too when SRCREV is changed
5PV = "1.23.2+git${SRCPV}"
6
7S = "${WORKDIR}/git"
8
9SRC_URI = "git://busybox.net/busybox.git \
10 file://get_header_tar.patch \
11 file://busybox-appletlib-dependency.patch \
12 file://busybox-udhcpc-no_deconfig.patch \
13 file://find-touchscreen.sh \
14 file://busybox-cron \
15 file://busybox-httpd \
16 file://busybox-udhcpd \
17 file://default.script \
18 file://simple.script \
19 file://hwclock.sh \
20 file://mount.busybox \
21 file://syslog \
22 file://syslog-startup.conf \
23 file://syslog.conf \
24 file://busybox-syslog.default \
25 file://mdev \
26 file://mdev.conf \
27 file://mdev-mount.sh \
28 file://umount.busybox \
29 file://defconfig \
30 file://busybox-syslog.service.in \
31 file://busybox-klogd.service.in \
32 file://fail_on_no_media.patch \
33 file://run-ptest \
34 file://inetd.conf \
35 file://inetd \
36 file://login-utilities.cfg \
37 file://recognize_connmand.patch \
38 file://busybox-cross-menuconfig.patch \
39 file://0001-ifconfig-fix-double-free-fatal-error-in-INET_sprint.patch \
40 file://0001-chown-fix-help-text.patch \
41 file://mount-via-label.cfg \
42 file://sha1sum.cfg \
43 file://sha256sum.cfg \
44"
45
46EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
47
48do_install_ptest () {
49 cp -r ${B}/testsuite ${D}${PTEST_PATH}/
50 cp ${B}/.config ${D}${PTEST_PATH}/
51 ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
52}
53
54DEFAULT_PREFERENCE = "-1"