blob: 0d0effef601dfb355a664bb7f6c068ad9ce1a20c [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Python bindings for libcurl"
2HOMEPAGE = "http://pycurl.sourceforge.net/"
3SECTION = "devel/python"
4LICENSE = "LGPLv2.1+ | MIT"
5LIC_FILES_CHKSUM = "file://README.rst;beginline=166;endline=181;md5=57e5ab0c0f964533fc59d93dec5695bb \
6 file://COPYING-LGPL;md5=3579a9fd0221d49a237aaa33492f988c \
7 file://COPYING-MIT;md5=e8200955c773b2a0fd6cea36ea5e87be"
8
9DEPENDS = "curl python"
10RDEPENDS_${PN} = "python-core curl"
11SRCNAME = "pycurl"
12
13SRC_URI = "\
14 http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
15 file://no-static-link.patch \
16"
17
18SRC_URI[archive.md5sum] = "f44cd54256d7a643ab7b16e3f409b26b"
19SRC_URI[archive.sha256sum] = "6e9770f80459757f73bd71af82fbb29cd398b38388cdf1beab31ea91a331bc6c"
20S = "${WORKDIR}/${SRCNAME}-${PV}"
21
22inherit distutils
23
24# need to export these variables for python-config to work
25export BUILD_SYS
26export HOST_SYS
27export STAGING_INCDIR
28export STAGING_LIBDIR
29
30BBCLASSEXTEND = "native"
31
32# Ensure the docstrings are generated as make clean will remove them
33do_compile_prepend() {
34 ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py docstrings
35}
36
37do_install_append() {
38 rm -rf ${D}${datadir}/share
39}