blob: ffc03e5c709cae59fbb27c1430969c3acaef50b0 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Socket-based service activation daemon"
2HOMEPAGE = "https://github.com/xinetd-org/xinetd"
3
4# xinetd is a BSD-like license
5# Apple and Gentoo say BSD here.
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=8ad8615198542444f84d28a6cf226dd8"
8
9DEPENDS = ""
10PR = "r2"
11
12SRC_URI = "git://github.com/xinetd-org/xinetd.git;protocol=https \
13 file://xinetd.init \
14 file://xinetd.conf \
15 file://xinetd.default \
16 file://Various-fixes-from-the-previous-maintainer.patch \
17 file://Disable-services-from-inetd.conf-if-a-service-with-t.patch \
18 file://xinetd-should-be-able-to-listen-on-IPv6-even-in-ine.patch \
19 file://xinetd-CVE-2013-4342.patch \
20 file://xinetd.service \
21 "
22
23SRCREV = "68bb9ab9e9f214ad8a2322f28ac1d6733e70bc24"
24
25S = "${WORKDIR}/git"
26
27inherit autotools update-rc.d systemd
28
29SYSTEMD_SERVICE_${PN} = "xinetd.service"
30
31INITSCRIPT_NAME = "xinetd"
32INITSCRIPT_PARAMS = "defaults"
33
34EXTRA_OECONF="--disable-nls"
35
36PACKAGECONFIG ??= "tcp-wrappers"
37PACKAGECONFIG[tcp-wrappers] = "--with-libwrap,,tcp-wrappers"
38
39do_configure() {
40 # Looks like configure.in is broken, so we are skipping
41 # rebuilding configure and are just using the shipped one
42 ( cd ${S}; gnu-configize --force )
43 oe_runconf
44}
45
46do_install() {
47 # Same here, the Makefile does some really stupid things,
48 # but since we only want two files why not override
49 # do_install from autotools and doing it ourselfs?
50 install -d "${D}${sbindir}"
51 install -d "${D}${sysconfdir}/init.d"
52 install -d "${D}${sysconfdir}/xinetd.d"
53 install -d "${D}${sysconfdir}/default"
54 install -m 644 "${WORKDIR}/xinetd.conf" "${D}${sysconfdir}"
55 install -m 755 "${WORKDIR}/xinetd.init" "${D}${sysconfdir}/init.d/xinetd"
56 install -m 644 "${WORKDIR}/xinetd.default" "${D}${sysconfdir}/default/xinetd"
57 install -m 755 "${B}/xinetd/xinetd" "${D}${sbindir}"
58 install -m 755 "${B}/xinetd/itox" "${D}${sbindir}"
59
60 # Install systemd unit files
61 install -d ${D}${systemd_unitdir}/system
62 install -m 0644 ${WORKDIR}/xinetd.service ${D}${systemd_unitdir}/system
63 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
64 -e 's,@SBINDIR@,${sbindir},g' \
65 ${D}${systemd_unitdir}/system/xinetd.service
66}
67
68CONFFILES_${PN} = "${sysconfdir}/xinetd.conf"