blob: 54841c243363f15273c77488840e01340c56ab30 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A drop-in replacement for argparse that allows options to also be set via config files and/or environment variables."
2HOMEPAGE = "https://github.com/bw2/ConfigArgParse"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=da746463714cc35999ed9a42339f2943"
5
Andrew Geisslerd221e032020-07-10 16:13:21 -05006SRC_URI[md5sum] = "8978866babc7ff0994f691ebe48b5aba"
7SRC_URI[sha256sum] = "edd17be986d5c1ba2e307150b8e5f5107aba125f3574dddd02c85d5cdcfd37dc"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
9PYPI_PACKAGE = "ConfigArgParse"
10
11inherit pypi setuptools3
12
13PACKAGECONFIG ?= "yaml"
14PACKAGECONFIG[yaml] = ",,,${PYTHON_PN}-pyyaml"
15
16RDEPENDS_${PN} += "\
17 ${PYTHON_PN}-core \
18 ${PYTHON_PN}-shell \
19"
20
21BBCLASSEXTEND = "native nativesdk"
Brad Bishop996bc452019-12-02 13:05:15 -050022