Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Client for the Trivial File Transfer Protocol" |
| 2 | DESCRIPTION = \ |
| 3 | "The Trivial File Transfer Protocol (TFTP) is normally used only for \ |
| 4 | booting diskless workstations. The tftp package provides the user \ |
| 5 | interface for TFTP, which allows users to transfer files to and from a \ |
| 6 | remote machine. This program and TFTP provide very little security, \ |
| 7 | and should not be enabled unless it is expressly needed." |
| 8 | DEPENDS = "tcp-wrappers readline" |
| 9 | SECTION = "net" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | HOMEPAGE = "http://freecode.com/projects/tftp-hpa" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | LICENSE = "BSD-4-Clause" |
| 12 | LIC_FILES_CHKSUM = "file://MCONFIG.in;beginline=1;endline=9;md5=c28ba5adb43041fae4629db05c83cbdd \ |
| 13 | file://tftp/tftp.c;beginline=1;endline=32;md5=988c1cba99d70858a26cd877209857f4" |
| 14 | |
| 15 | |
| 16 | SRC_URI = "http://kernel.org/pub/software/network/tftp/tftp-hpa/tftp-hpa-${PV}.tar.bz2 \ |
| 17 | file://tftp-0.40-remap.patch \ |
| 18 | file://tftp-0.42-tftpboot.patch \ |
| 19 | file://tftp-0.49-chk_retcodes.patch \ |
| 20 | file://tftp-0.49-cmd_arg.patch \ |
| 21 | file://tftp-hpa-0.39-tzfix.patch \ |
| 22 | file://tftp-hpa-0.49-fortify-strcpy-crash.patch \ |
| 23 | file://tftp-hpa-0.49-stats.patch \ |
| 24 | file://tftp-hpa-5.2-pktinfo.patch \ |
| 25 | file://default \ |
| 26 | file://init \ |
| 27 | file://add-error-check-for-disk-filled-up.patch \ |
| 28 | file://tftp-hpa-bug-fix-on-separated-CR-and-LF.patch \ |
| 29 | file://fix-writing-emtpy-file.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 30 | file://0001-__progname-is-provided-by-libc.patch \ |
| 31 | file://tftpd-hpa.socket \ |
| 32 | file://tftpd-hpa.service \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 33 | " |
| 34 | |
| 35 | SRC_URI[md5sum] = "46c9bd20bbffa62f79c958c7b99aac21" |
| 36 | SRC_URI[sha256sum] = "0a9f88d4c1c02687b4853b02ab5dd8779d4de4ffdb9b2e5c9332841304d1a269" |
| 37 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 38 | inherit autotools-brokensep update-rc.d update-alternatives systemd |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 39 | |
| 40 | export AR = "${HOST_PREFIX}ar cq" |
| 41 | |
| 42 | EXTRA_OECONF += "--disable-option-checking" |
| 43 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 44 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 45 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
| 46 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 47 | # configure.in has errors |
| 48 | do_configure() { |
| 49 | oe_runconf |
| 50 | } |
| 51 | |
| 52 | do_install() { |
| 53 | oe_runmake install INSTALLROOT=${D} |
| 54 | mv ${D}${bindir}/tftp ${D}${bindir}/tftp-hpa |
| 55 | mv ${D}${sbindir}/in.tftpd ${D}${sbindir}/in.tftpd-hpa |
| 56 | |
| 57 | install -m 755 -d ${D}${localstatedir}/lib/tftpboot/ |
| 58 | install -d ${D}${sysconfdir}/init.d |
| 59 | install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/tftpd-hpa |
| 60 | sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/tftpd-hpa |
| 61 | sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/tftpd-hpa |
| 62 | sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/tftpd-hpa |
| 63 | sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${sysconfdir}/init.d/tftpd-hpa |
| 64 | |
| 65 | install -d ${D}${sysconfdir}/default |
| 66 | install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/tftpd-hpa |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 67 | |
| 68 | install -d ${D}${systemd_unitdir}/system |
| 69 | install -m 0644 ${WORKDIR}/tftpd-hpa.socket ${D}${systemd_unitdir}/system |
| 70 | install -m 0644 ${WORKDIR}/tftpd-hpa.service ${D}${systemd_unitdir}/system |
| 71 | sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/tftpd-hpa.service |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 72 | } |
| 73 | |
| 74 | FILES_${PN} = "${bindir}" |
| 75 | |
| 76 | PACKAGES += "tftp-hpa-server" |
| 77 | SUMMARY_tftp-hpa-server = "Server for the Trivial File Transfer Protocol" |
| 78 | FILES_tftp-hpa-server = "${sbindir} ${sysconfdir} ${localstatedir}" |
| 79 | CONFFILES_tftp-hpa-server = "${sysconfdir}/default/tftpd-hpa" |
| 80 | |
| 81 | INITSCRIPT_PACKAGES = "tftp-hpa-server" |
| 82 | INITSCRIPT_NAME = "tftpd-hpa" |
| 83 | INITSCRIPT_PARAMS = "start 20 2 3 4 5 . stop 20 1 ." |
| 84 | |
| 85 | ALTERNATIVE_${PN} = "tftp" |
| 86 | ALTERNATIVE_TARGET[tftp] = "${bindir}/tftp-hpa" |
Brad Bishop | 7f28bc5 | 2017-12-03 23:42:40 -0500 | [diff] [blame] | 87 | ALTERNATIVE_PRIORITY = "60" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 88 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 89 | SYSTEMD_PACKAGES = "tftp-hpa-server" |
| 90 | SYSTEMD_SERVICE_tftp-hpa-server = "tftpd-hpa.socket tftpd-hpa.service" |
| 91 | SYSTEMD_AUTO_ENABLE_tftp-hpa-server = "enable" |