Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | require gstreamer1.0-plugins.inc |
| 2 | |
| 3 | SRC_URI = " \ |
| 4 | http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-${PV}.tar.xz \ |
| 5 | file://configure-allow-to-disable-libssh2.patch \ |
| 6 | file://fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch \ |
| 7 | file://avoid-including-sys-poll.h-directly.patch \ |
| 8 | file://ensure-valid-sentinels-for-gst_structure_get-etc.patch \ |
| 9 | file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \ |
| 10 | file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \ |
| 11 | " |
Brad Bishop | a5c52ff | 2018-11-23 10:55:50 +1300 | [diff] [blame] | 12 | SRC_URI[md5sum] = "5d20a91d027708abcf924f6c1279dd25" |
| 13 | SRC_URI[sha256sum] = "910b4e0e2e897e8b6d06767af1779d70057c309f67292f485ff988d087aa0de5" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/gst-plugins-bad-${PV}" |
| 16 | |
| 17 | LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+" |
| 18 | LIC_FILES_CHKSUM = "file://COPYING;md5=73a5855a8119deb017f5f13cf327095d \ |
| 19 | file://COPYING.LIB;md5=21682e4e8fea52413fd26c60acb907e5 " |
| 20 | |
| 21 | DEPENDS += "gstreamer1.0-plugins-base jpeg" |
| 22 | |
| 23 | inherit gettext bluetooth |
| 24 | |
| 25 | PACKAGECONFIG ??= " \ |
| 26 | ${GSTREAMER_ORC} \ |
| 27 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ |
| 28 | ${@bb.utils.filter('DISTRO_FEATURES', 'directfb vulkan', d)} \ |
| 29 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \ |
| 30 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)} \ |
| 31 | bz2 curl dash dtls hls rsvg sbc smoothstreaming sndfile ttml uvch264 webp \ |
| 32 | " |
| 33 | |
| 34 | # the gl packageconfig enables OpenGL elements that haven't been ported |
| 35 | # to -base yet. They depend on the gstgl library in -base, so we do |
| 36 | # not add GL dependencies here, since these are taken care of in -base. |
| 37 | |
| 38 | PACKAGECONFIG[assrender] = "--enable-assrender,--disable-assrender,libass" |
| 39 | PACKAGECONFIG[bluez] = "--enable-bluez,--disable-bluez,${BLUEZ}" |
| 40 | PACKAGECONFIG[bz2] = "--enable-bz2,--disable-bz2,bzip2" |
| 41 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl" |
| 42 | PACKAGECONFIG[dash] = "--enable-dash,--disable-dash,libxml2" |
| 43 | PACKAGECONFIG[dc1394] = "--enable-dc1394,--disable-dc1394,libdc1394" |
| 44 | PACKAGECONFIG[directfb] = "--enable-directfb,--disable-directfb,directfb" |
| 45 | PACKAGECONFIG[dtls] = "--enable-dtls,--disable-dtls,openssl" |
| 46 | PACKAGECONFIG[faac] = "--enable-faac,--disable-faac,faac" |
| 47 | PACKAGECONFIG[faad] = "--enable-faad,--disable-faad,faad2" |
| 48 | PACKAGECONFIG[flite] = "--enable-flite,--disable-flite,flite-alsa" |
| 49 | PACKAGECONFIG[fluidsynth] = "--enable-fluidsynth,--disable-fluidsynth,fluidsynth" |
| 50 | PACKAGECONFIG[hls] = "--enable-hls --with-hls-crypto=nettle,--disable-hls,nettle" |
| 51 | PACKAGECONFIG[gl] = "--enable-gl,--disable-gl," |
| 52 | PACKAGECONFIG[kms] = "--enable-kms,--disable-kms,libdrm" |
| 53 | PACKAGECONFIG[libde265] = "--enable-libde265,--disable-libde265,libde265" |
| 54 | PACKAGECONFIG[libmms] = "--enable-libmms,--disable-libmms,libmms" |
| 55 | PACKAGECONFIG[libssh2] = "--enable-libssh2,--disable-libssh2,libssh2" |
| 56 | PACKAGECONFIG[lcms2] = "--enable-lcms2,--disable-lcms2,lcms" |
| 57 | PACKAGECONFIG[modplug] = "--enable-modplug,--disable-modplug,libmodplug" |
Brad Bishop | a5c52ff | 2018-11-23 10:55:50 +1300 | [diff] [blame] | 58 | PACKAGECONFIG[msdk] = "--enable-msdk,--disable-msdk,intel-mediasdk" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 59 | PACKAGECONFIG[neon] = "--enable-neon,--disable-neon,neon" |
| 60 | PACKAGECONFIG[openal] = "--enable-openal,--disable-openal,openal-soft" |
| 61 | PACKAGECONFIG[opencv] = "--enable-opencv,--disable-opencv,opencv" |
| 62 | PACKAGECONFIG[openh264] = "--enable-openh264,--disable-openh264,openh264" |
| 63 | PACKAGECONFIG[openjpeg] = "--enable-openjpeg,--disable-openjpeg,openjpeg" |
| 64 | PACKAGECONFIG[openmpt] = "--enable-openmpt,--disable-openmpt,libopenmpt" |
| 65 | # the opus encoder/decoder elements are now in the -base package, |
| 66 | # but the opus parser remains in -bad |
| 67 | PACKAGECONFIG[opusparse] = "--enable-opus,--disable-opus,libopus" |
| 68 | PACKAGECONFIG[resindvd] = "--enable-resindvd,--disable-resindvd,libdvdread libdvdnav" |
| 69 | PACKAGECONFIG[rsvg] = "--enable-rsvg,--disable-rsvg,librsvg" |
| 70 | PACKAGECONFIG[rtmp] = "--enable-rtmp,--disable-rtmp,rtmpdump" |
| 71 | PACKAGECONFIG[sbc] = "--enable-sbc,--disable-sbc,sbc" |
| 72 | PACKAGECONFIG[smoothstreaming] = "--enable-smoothstreaming,--disable-smoothstreaming,libxml2" |
| 73 | PACKAGECONFIG[sndfile] = "--enable-sndfile,--disable-sndfile,libsndfile1" |
| 74 | PACKAGECONFIG[srtp] = "--enable-srtp,--disable-srtp,libsrtp" |
| 75 | PACKAGECONFIG[tinyalsa] = "--enable-tinyalsa,--disable-tinyalsa,tinyalsa" |
| 76 | PACKAGECONFIG[ttml] = "--enable-ttml,--disable-ttml,libxml2 pango cairo" |
| 77 | PACKAGECONFIG[uvch264] = "--enable-uvch264,--disable-uvch264,libusb1 libgudev" |
| 78 | PACKAGECONFIG[voaacenc] = "--enable-voaacenc,--disable-voaacenc,vo-aacenc" |
| 79 | PACKAGECONFIG[voamrwbenc] = "--enable-voamrwbenc,--disable-voamrwbenc,vo-amrwbenc" |
| 80 | PACKAGECONFIG[vulkan] = "--enable-vulkan,--disable-vulkan,vulkan" |
| 81 | PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland wayland-protocols libdrm" |
| 82 | PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp" |
| 83 | PACKAGECONFIG[webrtc] = "--enable-webrtc,--disable-webrtc,libnice" |
| 84 | PACKAGECONFIG[webrtcdsp] = "--enable-webrtcdsp,--disable-webrtcdsp,webrtc-audio-processing" |
| 85 | |
| 86 | # these plugins have no corresponding library in OE-core or meta-openembedded: |
| 87 | # openni2 winks direct3d directsound winscreencap acm apple_media iqa |
| 88 | # android_media avc bs2b chromaprint daala dts fdkaac gme gsm kate ladspa |
Brad Bishop | a5c52ff | 2018-11-23 10:55:50 +1300 | [diff] [blame] | 89 | # lv2 mpeg2enc mplex musepack nvenc ofa opensles soundtouch |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 90 | # spandsp spc teletextdec vdpau wasapi x265 zbar |
| 91 | |
| 92 | EXTRA_OECONF += " \ |
| 93 | --enable-decklink \ |
| 94 | --enable-dvb \ |
| 95 | --enable-fbdev \ |
| 96 | --enable-ipcpipeline \ |
| 97 | --enable-netsim \ |
| 98 | --enable-shm \ |
| 99 | --enable-vcd \ |
| 100 | --disable-acm \ |
| 101 | --disable-android_media \ |
| 102 | --disable-aom \ |
| 103 | --disable-apple_media \ |
| 104 | --disable-avc \ |
| 105 | --disable-bs2b \ |
| 106 | --disable-chromaprint \ |
| 107 | --disable-daala \ |
| 108 | --disable-direct3d \ |
| 109 | --disable-directsound \ |
| 110 | --disable-dts \ |
| 111 | --disable-fdk_aac \ |
| 112 | --disable-gme \ |
| 113 | --disable-gsm \ |
| 114 | --disable-iqa \ |
| 115 | --disable-kate \ |
| 116 | --disable-ladspa \ |
| 117 | --disable-lv2 \ |
| 118 | --disable-mpeg2enc \ |
| 119 | --disable-mplex \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 120 | --disable-musepack \ |
| 121 | --disable-nvenc \ |
| 122 | --disable-ofa \ |
| 123 | --disable-openexr \ |
| 124 | --disable-openni2 \ |
| 125 | --disable-opensles \ |
| 126 | --disable-soundtouch \ |
| 127 | --disable-spandsp \ |
| 128 | --disable-spc \ |
| 129 | --disable-srt \ |
| 130 | --disable-teletextdec \ |
| 131 | --disable-vdpau \ |
| 132 | --disable-wasapi \ |
| 133 | --disable-wildmidi \ |
| 134 | --disable-winks \ |
| 135 | --disable-winscreencap \ |
| 136 | --disable-x265 \ |
| 137 | --disable-zbar \ |
| 138 | ${@bb.utils.contains("TUNE_FEATURES", "mx32", "--disable-yadif", "", d)} \ |
| 139 | " |
| 140 | |
| 141 | export OPENCV_PREFIX = "${STAGING_DIR_TARGET}${prefix}" |
| 142 | |
| 143 | ARM_INSTRUCTION_SET_armv4 = "arm" |
| 144 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 145 | |
| 146 | FILES_${PN}-freeverb += "${datadir}/gstreamer-${LIBV}/presets/GstFreeverb.prs" |
| 147 | FILES_${PN}-opencv += "${datadir}/gst-plugins-bad/${LIBV}/opencv*" |
| 148 | FILES_${PN}-voamrwbenc += "${datadir}/gstreamer-${LIBV}/presets/GstVoAmrwbEnc.prs" |