blob: 976c59b9c678f6c94c13d7f479726f829bd1d367 [file] [log] [blame]
Brad Bishop2ad7ce32017-07-09 23:41:49 -04001SUMMARY = "Phosphor Mapper Configuration"
2DESCRIPTION = "Meta-recipe, pulling in native recipes that wish to add \
3configuration files to the native /usr/share/phosphor-mapper filesystem."
4HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
5PR = "r1"
6
7inherit obmc-phosphor-license
8inherit native
9inherit phosphor-mapper
10
11PHOSPHOR_MAPPER_CONFIGS = " \
12 phosphor-dbus-interfaces-mapper-config-native \
13 phosphor-legacy-namespace-mapper-config-native \
14 "
15
16DEPENDS += "${PHOSPHOR_MAPPER_CONFIGS}"
17
18# To add namespaces and blacklists to the mapper configuration,
19# create a native recipe in your layer, and add it to
20# PHOSPHOR_MAPPER_CONFIGS with a bbappend to this recipe.
21# Recipes should set one of the variables below.
22# Consult phosphor-mapper.bbclass for additional information.
23
24# Add path namespaces to be monitored.
25PHOSPHOR_MAPPER_NAMESPACE = ""
26
27# Add interfaces to be monitored.
28PHOSPHOR_MAPPER_INTERFACE = ""
29
30# Blacklist paths from being monitored.
31PHOSPHOR_MAPPER_NAMESPACE_BLACKLIST = ""
32
33# Blacklist interfaces from being monitored.
34PHOSPHOR_MAPPER_INTERFACE_BLACKLIST = ""
35
36do_install() {
37 install -d ${D}/${namespace_dir}
38 install -d ${D}/${interface_dir}
39 install -d ${D}/${blacklist_dir}
40 install -d ${D}/${interfaceblacklist_dir}
41}