blob: 46427b749e35a20d31d0ec89de37e99c4dd572ff [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001SUMARY = "Corstone1000 platform Initramfs Image"
2DESCRIPTION = "This is the main Linux image which includes an initramfs kernel/rootfs bundle."
3
4LICENSE = "MIT"
5
6COMPATIBLE_MACHINE = "corstone1000"
7
8IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
9
10inherit core-image
11
12# By default all basic packages required for a bootable system are installed
13# by core-image . These packages are: packagegroup-core-boot and
14# packagegroup-base-extended
15
16inherit image-buildinfo
17
18IMAGE_FEATURES += "debug-tweaks"
19
20#package management is not supported in corstone1000
21IMAGE_FEATURES:remove = "package-management"
22
23# all optee packages
24IMAGE_INSTALL += "optee-client"
25
Patrick Williams8dd68482022-10-04 07:57:18 -050026# external system linux userspace test application
27IMAGE_INSTALL += "corstone1000-external-sys-tests"
Brad Bishopbec4ebc2022-08-03 09:55:16 -040028
Patrick Williams8dd68482022-10-04 07:57:18 -050029# TS PSA API tests commands for crypto, its, ps and iat
30IMAGE_INSTALL += "packagegroup-ts-tests-psa"